High CPU Cubase Studio 4 with SL


After completing a large film project I thought it was safe so I finally took the plunge and upgraded my 20”Imac from Tiger to Snow leopard with no major problems.

I did all the usual updates- Firewire solo driver, Steinberg elicenser software etc.

Before upgrading I could run at least 60 instruments with 3 instances of Kontakt 4.1.3 and Kontaktplayer 2.2.4 inlcuding sounds from Symphobia, Evolve, Evolve mutations 1 & 2, Hollywood winds, Reason 4 etc as well as Sylus rmx, Stormdrum 2
various plugins as well as a QT mov. without my computer struggling too much.

After the upgrade my computers CPU performance monitor is peaking around 50% with audio spikeing with just 8 instruments with the buffer size set to 2048.

I’ve done all the usual (repair disk permissions, Mac hardware test, trashed Cubase preferences) but with no obvious improvement I have also turned off “Growl” and “Norton anti virus”

Steinberg no longer support “Studio 4” so I’m now left with a project looming and No technical support.

Is there someone out there that can help me?

Imac 20” 2.16Ghz Dual core 3gig ram installed.
OSX 10.6.8

Firewire solo with latest 32bit driver installed.

Cubase studio 4.5.2


Audio Detective.


It seems that your computer is having issues with larger projects; you will need to optimize your new snow leopard. Here is a great way to get started: https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/optimizing-mac-os-x-for-daws-mac-performance-trouble-shooting.html

Meanwhile, anything you can do to lighten your processor’s load such as enabling CPU saver options in preferences, freezing effects to your tracks, and using any Ecomode options that your VSTi’s may have will be beneficial to your situation. Are you running the program in 64 bit?

Hi Bane,

Thanks for you’re prompt reply!

With regards to am I running the program in 64bit my machine says (in about this Mac) 64bit No! 32bit yes, so I just downloaded the 32bit audio driver and I have not changed anything in cubase so I’m assuming everything is 64bit.

I will have a look at enabling CPU saver options (which is new to me)

I’ve just had a look for it in preferences, where can I find it?


Audio Detective.

p.s. Just checked a cubase project and it was running in 16bit I changed it to 32bit float but it didnt seem to make much difference?

Well, you will need to make sure you are running in 64 bit. This doesn’t have anything to do with your bit depths of 16, 24, or 32/64 float.

As for the CPU options in your prefs, anything that looks like it will hog Cpu should be disabled: CPU save scrub mode enabled, Create Audio Images During Record disabled, Warn on Processing Overloads, etc.

You should also look under Device>Device Setup>VST Audio System and work with your disk preload which has a tendency to hog some serious RAM. Out of all this, I would give priority to finding out if you installed the 32 or 64 bit version of Cubase!

In Cubase 6 on Mac, the 32-bit and 64-bit are the same application, you can switch between them by changing a setting in the executable. But that could be different for Cubase 4.

Strophoid, do you know how to tell whether you’re running the 32 bit or 64 bit version of Cubase? I can’t seem to figure it out for the OP.

Try this

As I said, I don’t know if this also applies to Cubase 4.