High Latency with Cubase 7.5.2

I’m right in the middle of a project with a deadline approaching and the audible latency got ridiculously high all of a sudden (like half a second at least) without any apparent reason. There are no additional plugs, didn’t change a thing in the settings etc.; drivers are all updated. My selceted audio interface (RME Firefeace) indicates that the latency should be just under 3ms, but that clearly is not the case! Even if I delete every fx, all instances of instruments and leave just one audio channel in my project: the audible latency is still there. And it is not only effecting audio tracks but midi tracks as well. Turning ASIO Guard on or off doesn’t help either. But the most funny thing: When I activate old projects or open a new project no such things happen!! Everything is just fine. So I guess that Cubase must have messed things up pretty bad in my current project! Why else are all the other projects just fine and why else would this problem still occur if there is only one single track left.
Does anyone have an idea how to solve this problem? I am not too keen on bouncing every single track and try to write down all settings of everything I have done so far… I already tried to use a backdown created by Cubase - didn’t change a thing.
Anybody got an idea hot to fix that lateny problem??? Solutions are most welcome…

A similar problem was already described in another thread called “High Latency with Cubase 7.5.1”. Unfortunately, noone really solved the problem.

Couldn’t wait for solutions to come up, so I finally bounced each and every track and imported them into a new project where everything is back to normal now. Still I wonder: what happened in the other project…

Hi teaforfree,

are you using any plugin on that project that induces latency on its own? Have you tried enabling the “Constrain Delay Compensation”?