Hitpoints why is audio detection so weak ?

Hi,

for years years years i hope that hitpoint detection in cubase then nuendo would work. But let’s face it. It’s super crap.
even with a clear drum track you get get hitpoints randomly and have to adjust manualy.
here i’m working with an audio file from boom library. so it’s clearly 4 booms with high transient spaced with massive silence.
whatever the threshold / minimum length setting i’m faster doing it manualy.
this threshold thing makes me crazy. sometime you move it but i mean clearly you see the file is BELOW the threshold and still (!) nuendo drops a hitpoint there. then when you what to edit hitpoints it’s a nightmare where you have to click this little tiny arrow lock/ disable hitpoints.
Protools for years has this simple function where you press a shortcut and cursor move to next transient super efficient.
and i remember the “remove silence” (?) from protools where you set threshold and actually see the waves BELOW threshold beeing left. then you could auto add offsets and more.
also why is Minimum lenght limited to 1s ?!? at least for sound filed recording it would help to have settings to 10sec where you leave space in your take for room and silence.

… maybe i’m doing something wrong. tell me. oh of course if you use “beats” it works better… but still not good enough.
so i end up doing cuts with low zoom, then zoom max and “locate next event” to adjust.

https://www.steinberg.net/forums/viewtopic.php?f=245&t=140241&p=754725#p754725