Hitting [Enter] on the number pad after data entry


Hitting [enter] on the numeric pad is ‘play (from cursor)’. When I enter data into a plugin using the numeric pad then hit enter to confirm then sometimes Wavelab not only confirms the data input but also plays back from the cursor position too. This only happens in some plugins. In DMG Equilibrium I can enter frequencies, gains etc and then playback just carries on. If I enter a number in Fabfilter Pro-L and hit enter then the play goes back to the cursor position. Which is kinda annoying. UAD, Fabfilter and TDR seem to have this problem. DMG and Sonnox don’t. This different behaviour is split within Steinberg’s own plugins too. GE10 EQ changes play back. Peak Master just carries on. Hitting return to confirm data entry is consistent throughout. Is there any way of making this consistently ignore the play command when using the numeric pad to enter data? I’m on Mac.

I’ve noticed this too and learned to hit “return” on the keyboard rather than “enter”.

Maybe there’s a way to add a setting to solve this.

I didn’t know if it was a Wavelab issue or plugin. But it’s inconsistent within the included Steinberg plugins. I don’t have this issue with other DAWS. Hitting return is the obvious fix but it’s counter intuitive to my brain when I’m using the keypad.

It is not a Wavelab issue but a Wavelab feature. I am so used to having playback start from NumEnter that I would hate that behaviour to change. Teach your brain! :wink:

I don’t wish for the enter key to no longer control playback. Far from it! But when I double click on a plugin parameter, enter a number and then hit enter to confirm then I expect the enter key to confirm my entry and not alter playback at all. Once I’m done with data entry then I of course expect the enter key to return to its usual purpose. Some plugins allow this to happen. Some don’t.

No, I understand, but in my view the plugins that DO accept NumEnter for data input are the ones off - interfering with the playback function by taking it away.

But all other Wavelab shortcuts on the numeric pad are temporarily suspended during data entry. Like “/” and “*”. If I want to enter “2db” gain then I just want to tap 2 then [enter}.

It seems as though the decision for this behaviour is from within the plugin rather than Wavelab. It would be nice to have an option to “suspend use of [enter} during playback for certain plugins”.