Homebase for Sonar users

In Sonar, you could toggle an option to prompt a warning message that you are about to move an audio clip (event).
Is there any way to do that in Cubase?

bump

I hav’nt found a way of getting a prompt before moving a clip, but an event can be locked in place.

Select the event, Edit > Lock.

To lock an entire track, select the track, and in the Inspector click on the top section and click on the open padlock icon.
See page 99 of the manual for a picture of what I’m referring to, it’s next to the orange crotchet.

Thanks for the advice, ceemusic. One thing, I tried the link you posted but it looks like it’s broken. Could you try that again, please?
Thanks

Sorry, I don’t know why a url was made there- it’s just a sentence…

My point is that many backup Sonar projects by saving it to a new folder & checking the ‘copy all audio with project’ option.
This doesn’t work in Cubase so I’d advise checking out the backup project feature early on. (Its what Sonar should’ve had instead of the workaround that was mainly used because of Cakewalk’s horrible ‘Clean Audio Folder’ feature)

Thanks for the response. Unfortunately that wouldn’t be a solution since I am still working on the clips such as cutting and/or adjusting clip lengths, etc.

Thanks for the response. Unfortunately that wouldn’t be a solution since I am still working on the clips such as cutting and/or adjusting clip lengths, etc.

It is possible to do that, though not that obvious - I found it by accident.

  1. Select event and Edit > Lock.
  2. Do Edit > Lock again
  3. A popup appears showing Position Locked, Size Locked, and Others Locked. Deselect Size and Others, leaving only Position selected.

You can now cut and change the clip lengths.

Size and position lock are self explanatory, Others disables cutting, fades, and possibly other things.

Other than setting lock options, when I don’t want to accidently move things, I set the snap to bars 1/1.

:bulb: YES, that is definitely a doable work-around, thanks eric!

I have been a Cakewalk user for 20+ years from Cakewalk, Pro Audio 9, Sonar (many version, to Sonar Professional. I had edited the instrument file adding new devices and their respective patch names and values. I fortunately found Cubase script files on the web for the Roland XV-5080 and SD-50 devices. Copied them into Steinberg/…/Roland and the are now installed in my Midi Device Manager and working in the track inspector, that is I can select by device and patch name.

My problem is I decided I didn’t like the format of the SD-50 and decided to do a NEW device. I have never yet been able to get it to work. I contacted support, but either I can’t explain to their understanding or they don’t know either. So I decided to try this venue

I added a new device in the Midi Device Manager, by selecting Install Device/Define New. Gave it a different name for the SD-50 and it now appeared in the device list. Using the Midi Device Manager editing commands, I created the Folder , Patch names, and. Bank Select and Program Change Values I got from the working SD-50 device I put in 15 or some presets to try it.

Now comes the problem. When I import a midi files and try to use the new device in the track inspector, it appears in the selection list along with the working 2 devices. However the place where you would select a patch name, it will only allow the Bank Select value and Program Change value to be entered. Using the working SD-50 device I get the list of folders/patch names to select from.

Is there something else I need to do to complete the installation of the new device. After entering the new device in The Midi Device Manager and all the values , I just close it out. There are no boxes to check that say install.


Thus far I have been able to do most of the midi functions I used in Sonar, although it has taken some time figure out. But I have sometime left on my 30 day trial

Can you clarify something?
It sounds like the device works for patch select as long as you don’t import a MIDI file. Is that correct?

In Sonar there’s this fun thing called Retrograde, with which you can mirror a midi track (maybe audio too, I’m not sure), so it plays backwards. Is there a comparable function/script in Cubase?

For midi --> Select the midi event, go to midi menu, then functions and then reverse.
For Audio --> Select the audio event, go to audio menu, then processes and then reverse.

I should have said Install rather than import. Each time I start Cubase the new device is listed in the Midi Device Manager, but after selecting it in the project track inspector, than selecting it there, none of the patches I had added to the new device appear. I did try to use the export/import on the new device, but never could get that to work, but that’s another problem for another day.

I can’t seem to get the added patches in the new device to appear for selection in the track inspector.

I have figured a way to cheat the system. Made a copy of the SD-50 script I found on the internet, changed the file name, edited the device name in the script, than copied it into the same inactive/Roland file as the original. I than installed that new device using the Midi Device Manager. I am now able to modify that device to look like I want (similar to the ones I used in Sonar - habit I guess) and everything works fine for the SD-50.

I have another Roland module JV-2080 which I used occasionally and have no Cubase scripts on the web, so I still need to figure how to get a new dvice to be useful.

Thank you. Should’ve looked harder.

Hello community. 20+ years of Cakewalk Sonar user converting over. Yes things are different, better and maybe worse depending on solutions, getting used to it. So two things seem odd, not sure feature or bug. Thoughts?..

  1. When I close all my projects the Cubase menu bar stays up until i click to close X a few times - Bug or feature?

  2. Recording button weird. I can inadvertently, I guess by touching a track, flip tracks into record or not record mode while recording. Kinda like it but ummm sometimes oops not recording or recording when I didn’t mean to . - Bug or feature, Why?

  3. So this one not liking. In Sonar you attach a track to an converter input and it shows you the input level without direct monitoring. Seems like in Cubase that is only possible when you set an input to be direct monitored (I dont do/like that). Forces you to show input channels (to see input levels) and track to see post recording levels. So I need to show separate meters for input level AND recorded level. Seems odd, clunky for tracking, takes up mixer space. Really not sure why this is a good thing.

Thanks for finger exercising time typing response :slight_smile:
Mark

  1. much hated “feature” if you are on windows
  2. you can turn off auto-enable record in preferences.
  3. I think most of us will tell you that it is a good thing because it is in fact a separate track. in the inspector and on the mixconsole I don’t believe you can show the input level. However, on the channel editor, there is a weird double arrow button on the top row that will show all input and output routings channels as part of the editor window.

I tried that. But every time I use that function the audio comes out as “Paul is dead”. :laughing:

Press Ctrl-Q It will shut down the whole app Though one thing I’ve found is if you do that and your project isn’t saved, it prompts you with a Dialog “Do you want to save”
DO NOT PRESS YES, PRESS CANCEL
Save the Project and then press Ctrl-Q
Pressing Yes, will often ~50% of the time lead to Cubase crashing (still occurs in cubase 9.5) . I think cause it starts saving and before thats completely finishes it goes into project shutdown mode

:laughing: