Horizontal spacing within absolute tempo changes

Forgive me if this is covered elsewhere, but I can’t find any reference …

Is there a way to reduce the spacing between the text of an absolute tempo change, and the included metronome mark?


Can you show a screenshot of the problem you find with this and perhaps a Dorico file of the measure or two where it occurs?

Hi Derrek – it’s not a problem, as such. I believe that what I see is what’s intended, and it’s not excessive. However, it’s just that there is a little more space between the text and the metronome marking than my publisher would like. I just wondered whether there was a setting hidden somewhere to adjust the spacing.

And this is when you put the MM marking after the Text and Without parentheses. Correct?

Interesting, but clearly you want to comply with your publisher’s requests.

Indeed – text first, then MM. I’d like to oblige. It’s not a huge issue, but I felt there might be a tweak which I’ve not yet found! (no parenthesis)

There’s no way to do this at the moment, I’m afraid, Roderick. I’d need to go spelunking in the code to remind myself precisely what Dorico does here but I suspect there may be a fixed value being used for this, possibly a space in the larger tempo text size.

That was fun to google.

The only thing you might do to satisfy your publisher is hide the Dorico metronome mark and create a new one using the MusGlyphs font. You can reposition your newly created metronome mark in Engave mode. Or create a text frame and insert a music symbol (quarter note?) from the menu and create your equation. If you haven’t got too many metronome marks then this could be a good solution because you can adjust the size of each element of the equation to get it looking just right.

For an absolute tempo, I always write the word(s) only and then use the properties pane to set the MM. It then becomes exactly 1 space between the last word and MM.

Excellent…I‘ve been struggling with this spacing myself and this works perfectly.

Thank you, everyone – good ideas for a workaround. The current project is a new 45 min symphony, so it would mean a huge number to tweak! Clearly, this has been in the thoughts of others, so maybe it would be possible to have a global adjustment for this spacing in a future update.

On my Mac, with the properties pane visible, I first select the first tempo word, then in the properties pane;

  1. Click the Text field
  2. Delete any trailing space in Text field
  3. Press Enter
  4. Press Right Arrow (to jump to the next tempo marking)
  5. Go to step 1

This jumps through the tempi quickly without any need to find them “manually”.

(I would suggest that the Text field has a “trim” function. I don’t see any need for a trailing (or starting) space for tempi. And, as suggested above, a general setting of the horizontal space between the last Text character and MM.)