How can I increase the resolution of Midi CC data while recording?

Hi, I am interested to increase the resolution I can achieve when recording midi cc information. In my example I am recording Pitch wheel and find I would like to try to increase and see if that helps with what I am trying to achieve.

thanks

It’s a function of the device you’re using. Pitchbend itself is a high resolution control, having 16,000 available steps, as opposed to midi CCs which have 127.

Are you talking about the resolution of the values (like 2 semi tones up an down)?
Or do you mean the time resolution, ie. how many events can be recorded in a beat?

Sorry, I am talking about the time resolution

I can’t recall if the Automation Panel has an effect on this but you can try,

Automation Panel > Settings > Reduction Level

If you are drawing CC’s make sure snap to grid is off (top bar in the editor). Otherwise it wil quantise it to the grid which can be anything. This is also a way to minimize eevents by enabling snap to grid and set the grid for example to 1/16th. It will then draw an event every 16th.

Are you asking about actually recording your physical pitch wheel, or something else? Technically Pitch Bend is a special case in regard to midi continuous controllers.

Yes, Steve recording the pitch wheel but I’m using a virtual instrument. I’m actually talking about using plugin source (in my case midi guitar). I did some quick counts from both by synth midi controller and from the plugin, I am seeing 384 ticks per measure. In settings is says PPQ Base is 480, I’m just wondering if I can get more detail as when I am doing very fine vibrato techniques it looks like a saw blade curve when I zoom in on it.

did you try what I suggested?

My first guess would have been to increase the PPQ setting. Have you tried that already?

No, I don’t want to use the automation features. I want to use the midi CC editor under the Key Editor.

thanks

PS. I just read another thread about PPQ and you can’t change it in Cubase so… Ya :slight_smile:

You mean a physical midi guitar? What model? Can you not edit the sensitivity of how its fingerboard interprets your movements? That’s what is needed here, because changing the ppq setting doesn’t make a difference for this. The MIDI Display Resolution is for display and editing – that’s why it’s called MIDI Display Resolution.

Internally Cubase is sample accurate. So the sample rate is the resolution. This can easily be demonstrated.

  • set a project to 48,000 samples per second
  • set the ruler in the key editor to samples
  • set the metronome to 60 beats per minute
  • insert a quarter note.

Observe that the note is 48,000 samples long.

@LoveGames as an fyi, Automation settings affect only automation.

1 Like

Increasing PPQ still has an effect. If you double the value you can have twice as many events per measure.
If you record Pitch Bend it also depends on the speed of the song and fast you move the PB controller how coarse the result will look like. If you are unhappy with the current result, record the passage at half the tempo. Maybe that’ll help.

Since both my methods to count the maximum amount of individual ticks in a measure were exactly the same I think it’s fair to say it’s not a controller issue. 384 seems to be on the low side?

@Johnny_Moneto Good point about the tempo, that could be a real solution here, if I was to half the tempo of my project. I didn’t think of that.

I do not understand what you’re measuring, and can’t really tell whether your reply is informed by my previous posts.


384 ticks if in resolution if you count.

What samplerate are you in?

I’m guessing if MIDI/automation is sample accurate, than increasing sample rate would also increase resolution… but I could be wrong on that.

That image certainly doesn’t look right

@beerbong

Or slow the tempo down like @Johnny_Moneto said.

Ya, I know it looks very much like a staircase type of movement when you zoom in (that is from my synth pitch wheel).
That was something else I was wondering about to.

Not sure if that would be good enough, but you could change the staircase into more of a curve:

  1. select all the little dots in the controller lane
    – either drag around all of them
    – or click somewhere in the controller lane area, then press Ctrl/Cmd-a (select all)
  2. change the Curve Type setting from Step to Ramp/Curve

1 Like