How can I increase the resolution of Midi CC data while recording?

I think I’ve finally figured out how to draw many pitch bend events into the pitch bend lane without them automatically getting thinned out:

In the Key Editor:

  • set the Snap Type to Events
  • ensure that “snap” is On

Then draw away slowly to get lots of pitch bend messages.

If they happen to be staircases, [change them to Ramp/Curve]](How can I increase the resolution of Midi CC data while recording? - #22 by Nico5) as per my post immediately above this one.

Thanks, I was looking for that setting. Changing it mado zero audible difference, though. :slight_smile: :grinning:

So is it fair to say that the problem definition has now changed from Cubase not recording all of the incoming midi pitchbend messages?

I think we’d have to first determine if this is for sure a result of the hardware or a result of Cubase.

You could compare to other DAWs but other DAWs might perform some sort of data slew to smooth out, and the smoothing may be irrelevant because everything is going to be rounded to the resolution limitation of MIDI in the background anyways - which is probably the steps you see, and probably why it sounds no different.

ie, if you draw a curve using the new bezier curves - that’s actually a visual misrepresentation of what is going on, in the background, there is actually a data staircase…

bring on MIDI 2.0!!!

@LoveGames

We’re talking pitch bend - not CC here. So the resolution is much higher.

And before you say, that the curve doesn’t make a difference, please run a midi monitoring test to observe if there are additional pitchbend messages created between the explicit dots in the key editor.

1 Like

Thank you! It comes down to what the device is sending.

Don’t really understand why you’re not answering my little questions, @beerbong… I thought this topic was about a midi guitar sending pitchbend, not about editing or drawing in pitchbend.

1 Like

I was basing that on @beerbong saying there was zero audible difference

@LoveGames – it was simply wrong

by the way, this is just a display PPQ per 16th note.

You can set this up to 1000 which in turn changes the PPQBase to 4000

The PPQBase being per 1/4 note.

Which in turn implies a PPQM (per measure) of 16000.

Again - that is for display - and therefore the max resolution for editing.

I’ve not been able to find out what PPQM Cubase is running internally - it may not be a published number.


This Preference setting :


… leads to this editing precision:

I was responding to the fact that I did not hear the stair case effect I was seeing, however that was not my main issue but simply looked off to me.

@beerbong

You never described the problem around your musical intent but jumped right into what appeared the problem to you.

Now it seems that what you thought was the problem, ended up not being the issue preventing you from getting to your musical intent.

Without you articulating what your music intent was or what you heard compared to what you expected, makes this entire thread a rather frustrating experience for those like me, who have spent their own volunteer time in an attempt to help a fellow music maker.


In a last attempt to get this deeply unsatisfying feeling out of my head, let me take a final shot at asking you a clarifying question / along with a guess at the real problem:

Are you trying to use pitch bend (with the mod wheel or via drawing) to create a realistic guitar string bend from a guitar sounding VSTi?

And is what you’re getting as a sound either no pitch shift or what appears to be a jump to a different note?

If this is the problem, then I may have an explanation:

While most synth-oscillator based plugins feature very good pitch bends,
quite a few sample based VSTi plugins seem to have unsatisfying implementation of pitch bend. – This has nothing to do with the DAW, but is simply a lack of programming in the VSTi plugin.


If this isn’t the underlying issue, I’m out of guesses what you are trying to achieve and you’d have to explain the real issue some more.

That was my thought,
the staircase is just a visual representation of the rounding going on in the background

Thanks Nico5 and others for trying to help, and you have already. I’m sorry but pretty much feel that I resolved my initial question quite a few threads and that is that I have simply reached the limits of the pitchbend, nothing really to fix. I get pretty decent results actually and but if I can make it better that is what I need to try.
thanks

@beerbong
you could maybe mark one of the posts as the solution, so that we know you’re satisfied and no longer looking for answers. :grinning:

I think he was just more or less concerned about the visual look of the stepped staircase data after recording but has concluded that there is no audible difference if he were to redraw the staircase as smooth because essentially the same rounding will still take place in the background

One thing to note is that I definately hear a difference when I use the new pitchbend type with curves, so I don’t know what it’s quantized internally but that sounds good.

alright well this entire thread is just scattered with contradicting information

@Nico5 is there a way to make it so ‘Curved’ is the default application to MIDI cc recordings?

tthat’s perhaps what Steinberg needs to do here

oh - that could be…

Yes, however it wouldn’t be Cubase that does any additional rounding, but the plugin itself.

Cubase only sends extra pitch bend events when the Curve Type is set to Ramp Curve, but not when it is set to step.

But good plugins avoid zipper noises by interpreting stepped midi events as instructions along the lines of: “please move this control to the following new position as fast as possible while not making zipper noises” – And of course good digital hardware synths should be programmed the same way.

This is analogous to early Cubase versions having clicks unless you specifically programmed fades at the beginning at the end of audio events. For a number of years now, Cubase automatically does a lightning fast fade at the beginning and end of events to automatically get rid of those clicks.

So Midi 2 isn’t even necessary to get away from zipper noises - if everybody just smartens up a bit about how to interpret midi messages.

Old or bad plugins and hardware still give you the zipper noise. :scream:

I believe the MIDI 2.0 resolution is high enough that some sort of slewing could be used to smooth out things which is perhaps what some plugins already do.

My hope is that MIDI 2.0 can even slew MIDI 1.0 data to be more smooth, you do notice the steps if you are trying to do very subtle gradual parameter changes.

@Nico5 is there a way to make it so ‘Curved’ is the default application to MIDI cc recordings?

tthat’s perhaps what Steinberg needs to do here