How can I optimize playback of VSTs


For as long as I can remember over the last 15 odd years of using cubase (not so much the last 7/8 years), I’ve always had issues with playback of VSTs being so laggy.

For instance, lately I might have one VST in my setup and nothing else, just a single vst - Tone2 Gladiator 3. I pick a pad sound, play it and after a bit the sound will lag. I will have no audio inputs activate and be only using the VSTs in-built FX. I can’t for the life of me why it’s always been like this and gets worse with more VSTs added. Obviously this has been nightmare over the years, which has made making music quitre difficult.

Current setup is,
WIndows 10 Pro x64,
Cubase 10.5
Intel core i7-4790K, 4.00 Ghz, 4 cores,
Samsung 1TB SSD * 2,
8GB RAM (Will upgrade to 16 or 32GB soon),
Komplete Audio 6.


Any information regarding this and tips on how it can be improved would be greatly appreciated.



Maybe you should think over your settings?
32 samples buffer size is very stressful to the system
and 64bit float precision is not really necessary

Thanks, I’ll have a look into them. I think I took these settings from a YouTube video sometime back

Had a look at the recommended buffer size on the Native Instruments website and it recommended a buffer size of 128. Did that and at the moment it seems to have improved things, as I’m not seeing any playback issues. Will open a bigger project but so far so good. Thanks!