How do I change the default midi inputs for when new tracks are created?

Is it possible to set up Cubase’s preferences to only use the midi inputs I select when creating a new track?

When I create a new track, in the inspector, it defaults to “all midi inputs”. This is a problem because besides using a midi keyboard, I also have a Behringer control surface for faders, etc, which is set up as a Mackie user interface. If I don’t remember to immediately change the input on a new track to the keyboard only, as soon as I touch a Behringer fader, it does nasty things to my tracks because it’s trying to apply CC messages and my original settings are unrecoverable.

Have you considered excluding your Mackie control surface from “all midi inputs” in the Studio settings?

1 Like

Use Track Preset:

  1. Create a new Midi track,
  2. Change its Midi input to the desired port,
  3. Save it as a track preset.
    From then on create Midi tracks by using that preset.
    Downside: It requires more mouse clicks than just changing the inout manually each time. However, you can assign a key binding to opening the preset browser.

Alternatively you can exclude your Behringer input from “All MIDI Input”:
Studio-Setup -> MIDI -> MIDI connection setup: It is the last column.

Thanks for both the replies. I didn’t realize that the “All MIDI Input” was specifically for that field in the inspector. I thought it was a general descriptor for all MIDI going into the program.

1 Like