How do i delete/fix this in Dorico?

As you can see on the attached photo this looks aweful and i have no clue how to remove it. It’s probably extremly easy, but im new to Dorico and don’t even know what to look for.

Select the time signature then open the Properties panel. In the Time Signatures section click on the button for Cautionary at end of system and make sure that Hide is selected.

1 Like

Thanks for helping out.

If you have Dorico Pro, Elements, or an iPad subscription, there’s a corresponding Notation Option that allows you to set on a per-flow basis whether cautionary time signatures are shown. For flows where you have multiple time signature changes, this can be quicker than setting the property for each one.

There is likewise a property and corresponding Notation Option for cautionary key signatures.