how do i get my sustain pedal to work?

Hey guys, so I’ve got a korg microkey 2 midi keyboard and I’ve got a korg ds1h damper pedal, I’ve connected them and tried to record but there was no sustain. how do I solve that? cheers

  1. Is the pedal action bring recorded?
  2. Does the sound you’re using it on support sustain?
  1. Make sure your assignable jack input is set to sustain and or the sustain button if you are using the 25 key

the sound I am using is gm001 acoustic grand piano and I believe it does support sustain. I plugged the pedal into my midi keyboard and I played a few songs with it with that sound and it worked so I assume it does support sustain

I am sorry but I am super new to writing music with software and a keyboard. can you please walk me through the setting the assignable jack input step by step? thanks

Yes, that sound should support sustain (just checked on my system where it does).

Which version of Cubase do you have (Pro, Artist, Elements)?

Do you see Cubase responding to the pedal when you press it? There is a MIDI input indicator on the bar at the bottom it should indicate when either the keyboard is played or the pedal is depressed.

sorry for the late reply, I have been away from from my work station for a while to deal with some family issues. I use Cubase elements 9.5. I found the indicator, I pressed on the sustain pedal and the bar went up, same thing happened when I press on the keyboard, however the bar doesn’t stay up when I hit a note and then step on the sustain pedal. There is sustain happening but the bar doesn’t stay up, I wonder if that shows the problem?

No, that’s behaving as it should. There should be a signal on depressing the sustain pedal and then another on releasing it.
Since you only have Elements you don’t the MIDI List Editor which is where I’d go next by choice. Shall have a look at Elements later.

OK, here’s what to look at next.
1.Record some playing of your keyboard into Cubase on an instrument that you want the sustain pedal to work on. Use the sustain pedal on the recording.
2. Open the MIDI Key editor (Alt-K by default).
3. You should now see the notes you played and by clicking on the triangle (the triangle appears when the mouse pointer hovers over this area)near where I’ve highlighted in the screen-grab change the bottom section to display sustain (cc64) rather than velocity. You should then see if the sustain events are being recorded as they have been in the screen grab…they show up as grey blocks indicating where the sustain pedal was depressed.

Open your MANUAL to your midi keyboard and lookup how to assign the assignable jack input or if you have the 25 key controller look up how to enable that

got it working now. thanks a lot

Good to hear. :smiley:
If there’s one single step that got you there it might be useful to let us know what it was for the benefit of future users with the same issue.