How do I link Record and Monitor on MIDI tracks?

Hi folks,

Where’s the preference to make Record Enable automatically turn Monitoring on for MIDI tracks?

I’ve been through the manual and searched this forum and perhaps I’m using the wrong wording because it seems like it would be easy to find.

Basically I’d like it to be set up that whenever I see red on a MIDI track, I can play that instrument with no additional keystrokes.

thanks!
Matthew

Hi,

There is no this kind of (direct) preferences for any track type. In the Preferences > Editing > Project & MixConsole, you can enable Record on Selected MIDI Track. But you cannot enable Monitor.

Then in Preferences > VST, you can choose an Auto Monitoring option. For example “While Record-Enable”. But this is applied to Audio tracks only.

But you can play the Instrument immediately, once the Record Enable is On on the Instrument Track. You don’t need enable Monitor on the Instrument Track.

Thanks for the reply, Martin. Can you expand a bit on this part:

“But you can play the Instrument immediately, once the Record Enable is On on the Instrument Track. You don’t need enable Monitor on the Instrument Track.”

That means I can play it, and record it, but I won’t hear it - is that correct?

Hi,

No, it means, you will hear it while record, or even while stop. The Record Enable button is also kind of Monitor for the Instrument Tracks.

Ok, I can confirm that that ISN’T the case right now on my system. I can Record Enable any Instrument track and I can record the notes without any problems but I won’t be able to hear myself play live MIDI through that instrument until I manually enable the Monitor button on that track.

MIDI Thru Active IS enabled in Preferences so there must be something else I’m missing.

Hi,

Is Constrain Delay Compensation enabled or disabled in your project, please? Disable it.

Disabled and still no luck:

But it’s enabled on the Track, the orange button. Switch this Off, please.

Switched off and still no luck, unfortunately. Is there anything else it could be?

A-HA! I found the culprit:

Prefs > Record > MIDI > Record-Enable Allows MIDI Thru

Now everything is working as it should be.