How do I paste notes to a specific spot in the Key Editor?

So I copied some notes from a track in my composition by going into the Key Editor for that part and selecting and copying the notes. Now they’re in my paste buffer. I want to paste them into a different part by opening the Key Editor for that part. How do I paste them into the exact spot I want?

If I just do a Ctrl-V (Paste) it puts them at the project cursor position. Is there a way to manually move the project cursor to my desired spot? Is there a way to click on some spot in the Key Editor and say “paste them HERE”?

Related: How do I efficiently find this info in the manual? I went to the manual at https://steinberg.help/cubase_pro/v11/en/ and searched on
"Key Editor" paste
and got 612 hits! It ignores the quotes so it doesn’t see “Key Editor” as a phrase. What I’m looking for may be in the Manual but how do I find it efficiently?

Thanks in advance.

Hi,

The cursor position is the “HERE”. So you can place the cursor to the wanted position (by clicking to the ruler) and then Paste.

If I click on the ruler it snaps to the nearest line. For example if I click on 1 it snaps on the beginning of measure 15. If I click on 2 it snaps to the beginning of measure 16. Fine.

But I want to move the cursor to the beginning of Measure 11 because that’s where I want to paste-to. But it won’t let me click the ruler there because of the label “Addictive Keys 01” on the ruler. If I try to click above the label the mouse cursor turns into a raised hand. :raised_hand:

Hi,

Disable the Snap by using [J] Key Command.

there is a modifier click to place the cursor where you click

for me it’s alt+shift+click, can’t remember if it’s the default or not.

Hi,

The default one is Ctrl/Cmd + click.

Hi Art1.

I sometimes do this:

  • select the midi notes I wanna copy and copy with ctrl+c
  • while they are still selected press the L key (that sets your locator exactly to the place where you wanna insert your notes)
  • go to the other track and insert them just with ctrl+v
    thats it.
    Hope that works for you,
    Cheers

Disable the Snap by using [J] Key Command.

How is snap related to this? I only mention the snap behaviour to show that snap works properly but I can’t position the cursor where I can take advantage of the snap because of the label. “3” shows where I want to click on the ruler but it won’t let me.

there is a modifier click to place the cursor where you click
for me it’s alt+shift+click, can’t remember if it’s the default or not.

The default one is Ctrl/Cmd + click.

The problem is that it won’t LET me do a click (or a CTRL+click) on the left edge of the ruler because of the label. Over most of the ruler my cursor looks like this:
FourPointedArrow

…and I can click and it moves the Project cursor to the expected spot. But when the mouse passes over the label it changes to a hand and doesn’t let me click there.

Can you move the left locator 2 bars earlier (to bar 9) so the part label is moved over to the left? Then paste your material by clicking in the ruler at bar 11. Finally, move the left locator back to bar 11.

I know that sounds like a pain in the ass (because it is,) but it might work.

Post deleted

Yes, that works but Cubase is a very mature product so I assume there’s something simpler that would let me position the Program Cursor wherever I want without tricks. For me the best solution would be to get rid of that label (“Addictive Keys 01”) because the Part that’s being edited is already displayed in the Toolbar “Currently Edited Part” field, so it’s redundant at that location in the “piano roll” part of the editor.

Any way to do that?

Hold down Alt + Shift and click anywhere in the editor or project window (not on the ruler).

1 Like

Ta-daa! Thanks!

If input quantize is enabled, will the pasted notes snap to the nearest quantize value (e.g., the nearest 16th note)? Or does Alt+Shift click paste the notes at the exact position at which you click?

It just sets the cursor position. It doesn’t paste the notes. It is affected by snap setting.

Ah, got it. Thanks!