How do I prevent mapped CC from being recorded?

I have a generic control surface set up (Novation Impulse 61) and have the transport controls mapped out, CC 114-119. I notice that when I’m recording either MIDI part data or through automation write, these note on/off and CC’s are being captured with the part data. I have to remove the created data.

Is there a way to tell Cubase “don’t record CC data mapped to transport controls”? It’s the meta-MIDI.

Cheers!

  • Sean

I guess that your Midi track has “All MIDI ins” as midi input and that you have not followed what the Impulse manual says about configuring Cubase:

To set up the Impulse as a HUI control surface in Cubase, navigate to ‘Studio’ > ‘Studio Setup’ > ‘MIDI Port Setup’. The ‘Impulse HUI’ port MUST NOT have “in ‘all MIDI ins’” enabled.

Thanks for the tip. I actually tried out the HUI mode when they released the update, and it didn’t work well for me. However, the mention of the “All MIDI Ins” made me realize that I might be able to map the transport controls to a different channel than the rest of the keyboard.
With the mapping I created, I was able to add an ‘undo’ command to the ‘loop’ button control, which is super useful.

For giggles I’m going to try the HUI thing again. It seems to have a lot of promise, but I just couldn’t get it to be that useful. I think I was looking for continuous encoder support at the time and didn’t give it a fair chance. (Seems the “continuous encoders” on the Impulse are only continuous under Ableton)

Open for any other tips!

Thanks!

You shouldn’t “map the transport controls to a different channel than the rest of the keyboard.” Transport controls are mapped to a different midi port, specifically designed to keep things apart.

Impulse actually have 3 different midi ports (with 16 channels each) for various purposes, and by default the transport controls are on a separate port. The reason as to why you got them recorded on your midi track was because you hadn’t removed the other ports from “All Midi In”.

Please check the user Impulse guide page 31 on how to configure Cubase.

I’ve read through the Impulse manual, quite a few times.

In my case I was trying to set the keyboard up to primarily have the ability perform an “undo” action for the loop key, and it works perfectly when I switch the transport controls to use “CC” mode. I understand that when the transport controls are in MMC mode they come across as sysex events. I was also able to enable Cubase as an MMC slave and they worked as transport controls (albeit with weird non-stop FF and RW).

Also, using a few presets (1-4), with the transport in CC mode, they all seem to be sending similar data… 114-119… on channel 1. (I’m using MIDI-OX to inspect the traffic)

So this statement:

Transport controls are mapped to a different midi port, specifically designed to keep things apart.

It seems that that’s not entirely true except for when the keyboard is in HUI or MMC mode for transport controls. Also, the Impulse manual, page 31, only describes using the keyboard in HUI mode. I have that working fine, as I did before, but never really gave it a fair chance as I was focused on trying to get the encoders to be continuous.

I think I can solve my problem using the tips you mentioned. MMC seems to be klunky and rigid. HUI does seem to work, with the most flexibility. Now I’m trying to solve the riddle how how CC7 can be changed in that mode to allow me to adjust the volume of the current selected track, and of course, map an “undo” button.

I appreciate the help!