How do I remove an expired trial licence.

I have put this question to the Steinberg Support twice, but they haven’t even bothered to answer. So, therefore, my last hope is that someone here can help.

How do I remove an expired Cubase 7 trial licence from the eLicenser Control Center? On the Help page, it is stated:
“To remove a license that you do not need and don’t want to remain on your eLicenser anymore, please click the respective license’s “Remove License” button (in the “Licenses” list).
An Internet connection is required to complete the process. Please follow the onscreen instructions.”

I can’t find any “Remove License” button, and “Remove License…” in the “Actions” menu is greyed-out.

I expect to receive my upgrade on Monday, and the last thing I need is an expired trial-licence screwing things up. Any help is greatly appreciated

Thanx

Shouldn’t screw anything up. I’ve never deleted a licence and i’m on the latest version (full 7) upgraded multiple times from Artist 6

it shouldn’t screw anything up , ive been wondering on how to remove old trial licenses that have expired from my elicencer as it’s bloody annoying seeing the old red ones that you can’t remove .

Hehe … G-String , I share the same frustration like yourself … Hope some kind of solution appears someday… :slight_smile:

Are the expired licenses on the USB dongle or on the Soft license? In my experience, the trials that go on the USB dongle, can be erased when they expire (Wavelab, for example). The trial licenses that go on the soft license can not be erased.

I need help on this too … i would like to take out the trial eLicenser for cubase 8.5 pro

Solved for me. You have to delete (or rename if you are chicken like me) this file: SeLicenser.sel

It is located in “C:\ProgramData\Syncrosoft” on a windows machine

( the “ProgramData” - folder is a hidden system folder, make sure that you see it: Organize => Folder and Search Options => “View” Tab)

or here on a mac: /Library/Application Support/Syncrosoft Soft-eLicenser/

4 Likes

ah ah ah … worked for me, and I am a chicken
thank you

treetop327, are you aware that you probably have posted a way to crack (hack) eLicenser protected software, On the Steinberg forum, to boot.

If you can remove the demo license, what’s to prevent you from installing a new demo licence and get a new demo-period (and keep doing so)? Isn’t that the reason you can’t “legaly” remove it in the first place?

This does not do anything like that at all. Rest assured, the elc is more sophisticated than that.

Also, this procedure is also outlined in a SB knowledgebase entry.

Why is this so convoluted? Why cat this be as simple as removing it from the ELC action list? I wonder sometimes with Steinberg. A lot of there systems need simplifying. Especially when trying to re-download licenses on certain products you’ve had for sometime.

1 Like

same question here

1 Like

I have this problem too. I deleted the Syncrosoft folder from Application Support and it made no change. Pretty average programming really. I would have thought that the process of trial/full purchase would be expected client behaviour.

Me too, but in my case I was trying to activate a Dorico’s educational license (1.0, I think) after trial expired (1.2). The trial is on my usb, and I can’t erase it. End up having to install the new license on Soft-elicenser because it wouldn’t install on USB. At least Dorico is working but I am not sure if I can move my license to dongle, or if i will have some issues in the future… Guess I don’t get this Steinberg license thing at all…

Thanks treetop327! …for doing Steinberg’s job!!

Your fix worked for me :slight_smile:

Old thread, but very current issue for me.

Recently I started getting error messages while running eLicenser maintenance on steps 3 and 6. Basically the error said " It appears this copy of soft-elicense was not generated on this computer. You must contact your software vendor to blah, blah, blah.’ I just clicked ‘Cancel’ and Cubase 9.5 started without issue. Seems that there was an old expired soft-eLicense from a Cubase trial that I downloaded many years ago. I wasn’t able to deleted the expired trial off of the eLicenser through the latest downloaded eLicenser utility app. But the solution above, simply renaming the ‘SeLicenser.sel’ file fixed the issue.

Now the maintenance runs completely through all steps without any error messages or hangups. And the correct current licenses show up and work correctly.

Many thanks to treetop327!

Thanks treetop327! Your solution works perfectly. I just renamed “SeLicencer.sel” to “OLD SeLicenser.sel” - worked like a charm!

Doesn’t work anymore. It says file is protected in an object server.

Where is this file on mac?
cant see it in library/Application support

This still works. I just did it (Windows 10 Pro, Cubase 10.0.20 Pro). Thanks again, treetop327!