How do you "allow your browser to open Steinberg Download Assistant"?

After loading the Steinberg Download Assistant and clicking on the red “Sign in” button, my browser brings up a new tab with the following message…

Authorize Steinberg Download Assistant

To authorize Steinberg Download Assistant, you must allow your browser to open Steinberg Download Assistant. Once authorization is completed, you can close this page and continue working with Steinberg Download Assistant.

How does one do that? I’m using Firefox and when looking through the settings, the closest thing I can find is under General Settings / Files and Apps: If you filter for “steinberg” 3 items are listed, one of which is “net-steinberg-sda” which is set to “Use Steinberg Download Assistant.”
Other possibilities are that I can set exceptions for blocking popups, and warning when websites try to install add-ons which I added an exception for “https://steinberg.net” for each.

Where else would I go to 'allow my browser to open Steinberg Download Assistant?"

I stopped using firefox for stuff like this. I still use firefox but, for certain stuff I use DuckDuck browser.
Do you use Ccleaner to empty cache stuff ?
Also i have never remember websites or cookies etc.
When i start to use this a small box appears saying allow steinberg to open browser, so, I tick this and everything is OK. Now I’m not sure if that’s a browser box or a windows box. Which version of windows are you running ?

It should open without user intervention. If not, an OS security feature is preventing this.

OK, not sure what happened, but I posted a reply but its gone now! Then when I try to reply again part of my text from the failed post is already here! Something screwy with this forum software! Anyway…

I’m running Windows 10. No, I don’t use Ccleaner.

However, you mentioned cache so I cleared the cache in Firefox and now things work just fine!.. except that the same message that I need to enable SDA in my browser still pops up. (wha?) OK, whatever. Weird glitch?

In conclusion: So both of you are implying that this message is wrong? I should never need to allow SDA to open in my browser? That’s just taken care of? The message was 100% useless and the problem was elsewhere (faulty data in the cache)? I’m confused!

Searching the web for a solution to this shows years of people having problems with this message. If the message is wrong and prevalent, why hasn’t Steinberg fixed it? Its confusing enough that I have to use two separate logins with Steinberg.

No, at least not I. What I said was

Or you hit send without realizing. The forum’s working okay.

But it actually works. There is no way to know what the exact prob was on your system, withg the info provided, and the Internet is the complaint department for the world, not the compliment department. lol.

Apart from maintaining Firefox (prefs: empty chache or delete history etc), just try another browser like Edge, Chrome, Safari etc. The expected behaviour is that a window /pop-up opens and asks via a checkbox. Hint, could also be the block popups setting in Firefox, but really, I’d just try Chrome or Edge.

1 Like

OK, I am not sure how to respond. Very little of what I’m getting back even makes sense to me.

Admittedly, my brain is broken. After working in IT and Mechanical Design/Drafting for 2-1/2 decades (which I was very good at), my Autistic mind couldn’t handle the demands of this NeuroTypical-controlled world. I suffer severe anxiety, depression and C-PTSD now, which killed most of my smarts but turned my music genius on (apparently, great music requires broken brains).

Again, the message that lots of people across the internet get (myself as well as stated in the title of this thread) is that Steinberg is asking us to enable SDA to open in our browser, but nowhere was I ever able to find instructions on how to do that.

But apparently that isn’t actually the problem; we don’t need to enable SDA to be opened by our browser as that’s all apparently taken care of (I assume when SDA was installed? I don’t care.). I took the message literally as the problem I needed to resolve, when its not the issue at all. So this request that pops up in our browser tab means absolutely nothing. Its misleading.

I’ve seen suggestions like turning off antivirus software, and even making sure your clock is actually set dead accurate. I didn’t think any of that applied to me as I was trying to figure out how to obey the faulty message’s instructions, instead. But in my particular case, the problem was that something in Firefox’s cache prevented SDA from being able to function properly. This was the first time I had seen from anyone the suggestion to clear the cache. It most certainly wasn’t an OS security issue in my case.

Its a major bug that Steinberg asks you to do something that has nothing to do with the problem and then leave that bug there for years. But new features seem to be far more important to the vast majority of software companies than actually fixing bugs. My CAD software, as an example, that I paid thousands of dollars for has been slowly disintegrating into a pile of useless trash over the many years I’ve been using/“upgrading” it.

And what’s more, I know what I saw; I posted a reply and my complete reply showed as posted. The next day when I came back to this, that posting was strangely grey, but it was all there. I also couldn’t do anything; all the reply buttons were gone and no new replies were showing. So I refreshed the page, everything came back looking/functioning normally, except my last post was gone, and the first couple of lines from that post were sitting in the ‘create new post’ area. Then I discovered we had an R3 burst from our sun today. Gamma rays like to flip bits so maybe it was that… or this forum software is screwy. Like I alluded to earlier here, I worked in IT for almost 20 years, and the bugs have always been the most maddening thing about computers. My mind is broken from all the stupid stress of life and now I just want to try and see if I can make a living from the only option left to me, writing and recording my music. But unfortunately, about 1/4 of the time, I’m fighting bugs still!

Not trying to pick a fight, but I keep trying to believe that maybe someday, the younger generations will pay attention to the experienced and save themselves even more problems. Just like I used to when I was young. I ended up broken anyway!

Thank you @ADRIAN_DIX; clearing the cache fixed the problem.

I’m done here.