How do you correct an incorrect tempo mid-project

I am revisiting the very first project I ever mixed in Cubase. The tracks were originally recorded in garage band. I imported them as .wav files, including the drums (so the drums are just an audio file, not midi). When I imported I neglected to identify and set the tempo :astonished: (be gentle; I said this was my first project ever) so it defaulted at 120. The song is more like 135bpm. After importing, I recorded several more files, mixed etc. I got to the end and decided the drums are lame, so I want to use Groove Agent to add midi drums. Of course, they import at 120bpm. I have tried stretching. However, the initial tracks don’t line up with the beat timing, since the grid is based on 120 bpm but the tracks are faster. I have gotten pretty close, but… it is still a mess.

Is there a way to get the tempo of the project established at 135 (short of starting with stems and reimporting/remixing/reautomating the entire project) without Cubase altering the speed of the tracks recorded in Cubase? When I change the project tempo it seems to change the tracks recorded in Cubase, but not the tracks I imported.

Thanks in advance!

The song is “more like 135 bpm” or it is 135 bpm?
If it is “more like”, then Setting the Project to 135 will not make the drums work very well, unless you create a more or less precise tempo map.
If the tracks are 135 bpm, disable “Musical mode” for all Clips, set the Project tempo to 135 bpm and the Import the MIDI drums.

Lol. Point taken. I will nail it down, because by “more like”, it is actually 135.3 BPM (ugghhh).

Thanks, I will try that.

Yes, but if it is fixed at 135.3 it is not as complicated as "it is between 134,5 and 135,3 varying all the time.

Unfortunately, this did not work. I went to the tracks in the pool. Musical mode was already unchecked for all tracks. I changed the tempo. Some tracks behaved as expected and did not speed up. A few tracks (vocals, for example) sped up to match the new tempo. I see nothing different in the pool track that would indicate why certain tracks are speeding up.

Any other ideas?

Regardless, thank you so much for your responses!

Did the tracks Speed up, or did the Position of the different events Change?

As I undo and redo starting points do not seem to change. HOWEVER… it appears the events may be being stretched.

I have now confirmed this. In the tracks which are out of synch, the event length is longer when I change the tempo. In the tracks responding properly, the event length does not change.

The tracks are being stretched when I change the tempo. In researching, it looks like I need to change to linear time. However, I am using Elements, not Pro and my tracks do not have that option. Looks like I am stuck, unless you know of another way to address this. I guess I just found my first reason to upgrade.

Thank you for all your help.

Can’t you just set the tempo and then re-import only the audio that is stretched (to a new track) and see if it plays ok now? Try duplicating and renaming the audiofiles before importing …