How do you reamp properly? - getting echo

I’m reamping a sound file in Cubase and trying to record it, but when playing the audio file from Cubase and recording the amp, it also spits back out the mic’d signal back into the amp and creates a short echo. The interface I’m trying to do this with is a Firestudio Project.


Create a mono out for the reamp and mute your speakers/monitors.

Thanks, I’ll check the output bus.

Assuming you have the amp/mic isolated from the control room you should not need to mute the speakers/monitor.

As mentioned make a mono output buss, select this buss to output the guitar track (thus taking it out of the monitor chain), connect you re-amp box to that mono output from your soundcard, connect to amp. Make a new track for the re-amp and have that routed normally to your main L/R buss. That’s it! you should be able to monitor the re-amped version with the rest of the mix so you can tweak the mic/amp settings.

I’m not having luck with this. I made a mono bus that was assigned to my Firestudio Project’s output 4. Then I connected the input of my reamp device to my FP’s number 4 output, and the output of the reamp device to my amp’s input. Then I enabled the output 4/5 mix in the FP’s control panel in Windows. When I do so, it doesn’t play what I have set to output 4, but whatever is set to my main outs is played through the Firestudio’s output 4, and through my reamp device. I’ll contact Presonus on Monday when their telephone tech support is available, but is there something I could be missing?

I would have thought you would make an output in VST connections for mono out 4 (or whatever) then select the guitartrack to output 4 and you should have no need to go into the Firestudios control panel.

Instead of sending your recorded guitar to the master bus (or your main stereo out), you should send it to the reamp output.
I don’t know why you’re dragging the FP’s control panel into this.

That’s what I’ve tried, sending it to a mono bus to which the reamp device is connected, but no sound passes. When it’s sent to my main outs it passes through the output the reamp device is connected to. Setting it to send to bus 4, with the reamp device connected to output 4 is giving me no sound.

I don’t know why you’re dragging the FP’s control panel into this.

Only to enable the output, otherwise sound doesn’t pass through it.

In this image, I would click where it says Daw 3/4 on the right, and press the blue power button to turn it on. With it off, like I said, no sound passes regardless of how I have my buses set. With it on, sound passes when my recorded audio is sent through my main outs, but still no sound passes when it’s set to send through output 4.

Sorry if this is obvious, but you have definitely made a new connection in VST Outputs, and set the main output of the reamp channel to that output?

Yes. And I just edited my previous post a bit.

If in the mixer (cubase) with the outputs showing you see your stereo 2 buss and the mono channel 4 output, if there is activity on all the output meters then cubase routing is correct, that would leave the sound card control panel configuration as the fault!

Thanks for your help, though I still have not been able to remedy the issue. It does seem like it probably is a Firestudio problem and so I’ll contact Presonus. But here is (hopefully) the full picture.

These are my software settings. With this configuration no audio is sent through the reamp device (which is connected to the FP output 4) and to the amp. If I set the reamp track to out to 1/2 and then click on Enable Mix in the FP control panel, the audio is then sent to the amp, but then it also loops and creates my feedback/echoey problem.

Well the ports 3 and 4 are showing as inactive!

I don’t know your soundcard but you must have got the card setup wrong, I would set the soundcard control panel back to it’s default settings and start again.

It seems to be a problem with the driver or with the Firestudio device. After talking to Presonus and installing the latest driver, the audio is sending through random port settings in Cubase all the time (despite only having a device connected to out 7) : 1,2,5,7… then suddenly only 7… then maybe 4,5… it’s changing all the time.

How strange!

I hope you get it sorted as re-amping should not be that hard! and is very worth while.