How do you select a group channel via the mixer so that it shows all associated tracks ?

Is ir possible to select a group channel via the mixer and have it automatically only show the associated tracks of that group in the mixer, without having to select the group track in the project window first ? Currently I can’t see any way of doing this. So I need to keep going back and forth from the full screen mixer to the project window to find the next group track and then hop back to the mixer. Can it not all be done in the mixer ?

Also I wish when you selected a channel in the lower zone mixer that it automatically showed the corresponding track in the project window and placed it in vision. But it’s always buried somewhere and you need to hunt to find it.

Hi drdrdrdr,

Not sure I completely understand what you’re trying to achieve (I’m not clear why hopping back and forth to the Project window helps?) so forgive me if my explanation doesn’t give you exactly what you need…

I’m interpreting what you’re asking for as “select a group channel in the mixer window, press a button/key/menu item and show the associated tracks that are in the group channel within the mixer window”. There is a way to use “visibility agents” in the mixer window to “Show Channels that are connected to the first selected channel” so when you select the Group Channel in the Mixer window, then right mouse click for the menu, and look for “visibility agents” you’ll see the option in there. This will then show any tracks assigned to that Group Channel (and for me the output Master channel shows too) and hide all the rest of the mixer channels. There is also an option to “undo visibility changes”, which does exactly that, putting things back as they were before you hid everything. So you can assign both commands to keys in the “Key Commands” in the Edit menu… I just set the “show channels…” to the “[” key and the “undo visibility change…” to the “]” key and they allow you to show and hide the associated channels in the Group Channel you selected with one key press.

This frustrates me too… as it seems to work ok when all folders in the project window are expanded (I think) but not if they are “closed”. I think other users have had similar issues so possibly a bug fix or feature request.

Hope that helps but if not, just clarify the problem and I’ll see if I can help sort it.


Thanks for that. The issue I realised is that even though I had ‘show selected channels associated tracks’ selected. I didn’t realise you had to select that option evey time you selected a new group channel in the mixer. I thought once that option was selected it automatically did that evey time you selected a new track but it doesn’t seem to which is a bit odd. But at least now I know. Thanks