How do you stop Dorico receiving MIDI input?

I cannot stop Dorico receiving MIDI input data.

“Enable MIDI Input” is disabled in preferences, but as soon as you go into note entry mode, the MIDI input comes back on,

I have to turn my MIDI interfaces off, it’s the only way to stop Dorico reacting to MIDI data,

Is this a known bug, as it is really annoying

That’s also what I would have suggested, check the “enable MIDI input” in the preferences,
but since you already did that, it must be a bug then. I will check on Monday when I’m back in the office.
Or anyone else who can confirm this to be an issue?

There is also a way to disable specific midi inputs as described here, which you can try in the meantime.

Purely out of interest (and I really really mean it!) why would you not want MIDI input enabled when in note input mode?

The reason for wanting no MIDI input, is when I am working out what to write, I try out a few ideas using the piano, but this will play whatever voice Dorico was last in, and it is not in just input mode, the MIDI is received whatever mode Dorico is in. If Dorico only listened to MIDI input when in input mode that would be perfect, although maybe this is what is supposed to happen.

I can’t recreate what andyjh describes.

To echo what Ian says: if I have the caret enabled I get note input. If I don’t have the caret enabled I still get midi thru (i.e. I still get audio of what I’m playing, in whatever voice was last selected, but no notes are inputted to the score). I’ve not tried disabling midi input in preferences because it works the way I expect it to work.

I just mute the audio from my comp so that when I’m “figuring out my notes” all I hear is my physical instrument. Then I unmute the computer when I need Dorico to play back the score. Easy enough in the meantime.

Please can you try to disable MIDI input in preferences and let me know what happens, as it seems Dorico ignores this setting, once you have gone into note input once.

also as I have 24 MIDI inputs, there seems to be no way of telling Dorico which port to use (it seems to just listen to all of them all of the time)

I’ve just tried this and for me it works. I create a new project, double click in the stave to enable note input, and put in notes via MIDI keyboard. Depending on the setting in the Preferences, Dorico accepts or does not accept the input as expected.
I wonder what is different in your set up. Could you please choose from the main menu the item Help > Create Diagnostic Report? That will create a zip file on your desktop, please send it to u dot stoermer at steinberg dot de. But before creating that diagnostic report, please first do a little bit of MIDI input so that we can see in the log files your fault case.

That’s right, Dorico listens to all MIDI ports, but as Stefan mentioned in an earlier post, there is a workaround described here: https://www.steinberg.net/forums/viewtopic.php?p=642106#p642106