How I solved my C8.5.2 crackles and pops

Introduction:
I have been extremely frustrated with Cubase since the beginning of this year. I had random crackles and pops without any clear rootcause (or me not rootcausing thouroughly enough) looking into the wrong things or making assumptions or tweaking things that were not relevant.
I did several re-installs of Win10 1607 and Cubase 8.5.2, event went back to 7.5 and I was not able to solve the issue.
People advised about “core parking” “timer registry tweaks” and other redundant PRE WIN10 tweaks that no longer made an impact. I experimented with several Cubase VST Audio System settings, none made a significant improvement.

I knew I was not alone and I REALLY just wanted to blame MS & Steinberg, but guess what?!? It was me (or my system configuration if you will) I spend 2 days of in depth analyzing with LatencyMon and here is the list of issues that piled up DPC calls, which flooded the system, which in it’s turn caused “Hard Pagefaults” which caused Cubase to go nuts:
To be clear: LatencyMon advised my system to be able to play realtime audio without any problems. Ofcouse I had the Hard Pagefault bar go into the red every once and a while, but everyone has that right?

To break it down:

The Cubase symptoms:

  • no VST Performance meters clipping RED, VST performance hovering around 5%
  • little random “plops” and “pufs” you barely hear them, and sound very similar to a broken hardware device with a lose contact or leaking capacitor (imagine working hybrid with a 50k euro chain and hearing these kind of noises :smiling_imp: )
  • clear spikes or clicks, the “regular” latency symptoms
  • the “crinkled tape” sound, this one is interesting, you can’t really put your finger on it, but things just don’t sound right, it sounds most closely to a crinkled cassette tape, but not as excessive, very mild small artifacts and distortions, not sounding clean and tight.

The tweaks that did help reduce the problem:

  • You start off with a vanilla install of Windows 10
  • install Cubase 8.5.2, leave all VST settings to default, except Cubase Powerscheme. The advantage is that you can leave windows 10 on balanced, while going full throttle starting Cubase (DPC wise there is no difference between Steinberg Powerplan, or the High Performance plan of Windows 10)
  • Make sure your SATA controller runs AHCI and replace the Microsoft AHCI driver with the right Intel RST one for your chipset. In my case the 64bit Intel RSTe AHCI & RAID drivers v12.9.4.1000 WHQL did the trick.
  • Do the same for your USB Chipset drivers, replace MS drivers with Intel. Intel® Chipset Device Software 9.2.0.1030
  • Now, here comes the interesting part, AFTER doing above, go into Windows 10 device manager and RIGHT CLICK EVERY SINGLE DEVICE and choose “update driver”. Because of the intel inf files and different branches of drivers than Windows installed by default, you will now get updated drivers from Intel.
  • Please also DO install the latest Nvidia (357.70) because of the directX audio issues earlier this year. They have been resolved, you also need to make these tweaks in the Nvidia control panel:

Manage 3D Settings

  • Maximum pre rendered frames - 3
  • Multi Display - Single Display Performance Mode (if you have 1 screen ofcourse)
  • Power Management mode - Prefer Maximum Performance

This was the first part of my journey, reducing my problems about 50%. The 2nd part of my journey was looking at driver DPC calls and finding out what was causing those.

Drivers and apps optimizations:

  • I had HUGE DPC floodings with USBPORT.SYS. I’ve disconnected all of my midi USB gear and it was gone. When reconnecting, each device gererates about 500 DPC’s per minute, however my Elektron RYTM and FOUR, both in Overbridge Mode, generated 20.000 DPC’s per minute, as you can imagine, completely choking the USB bus. Putting these back in midi only mode in their system setup, brought them back towards around 500. > LEARNING: Each USB midi device, will eat DPC cycles, even when IDLE, sitting there, doing NOTHING. If powering off these devices (and reboot to release the driver) solves your issues, you might want to check the amount of DPC calls your device generates and either change it’s settings, if possible, or switch to DIN MIDI.
  • I have Office 2016 installed, it installs a background service called “Office Click2run” this is a HUGE offender of Hardware Pagefaults. You can not remove the service as office will no longer work, but you can kill it’s process tree, which unloads it until the next reboot.
  • I have Logitech Setpoint installed, the drivers are actually BETTER than the MS ones, but setpoint in the taskbar also causes hardware pagefaults, remove this program from your startup via msconfig
  • Same for SAMSUNG Magician

Together, ALL of the above sorted out my issues. Cubase audio is running smooth again.
The moral of this story:

  • Often the routecause is NOT obvious, it might be an underlaying process influencing another one.
  • Forget about the legacy tweaks floating on the internet for the last 15 years, they no longer work in Windows 10
  • Use LatencyMon, to scrutinize, even if it tells you your system is ok.
  • focus on the processes tab, sort by hard pagefaults and take note of the worst offenders
  • focus on the drivers tab and sort on DPC count and take not of the worst offenders
  • killing these, or changing drivers for these is your best bet.

Good Luck!

1 Like

Are you using the Elektron USB Overhub with your Elektron gear ?

Since last week yes, works fine on my renesas usb3 port

Cool, I was just wondering because the Elektron Overhub is specifically designed for the application (apparently) and states to use the following technology:

-Clever tech
Multi TT technology ensures ultimate USB data transfer performance. Every bit in its right place, at the right time. Overhub is a top performer.