How to assign 'Out' to a given instrument? PLZ help

When I load an instrument in a Halion bank it always gets routed to Program or Stereo 1; if, in the Out column, I select something else, for example Stereo 2 or Mono 1 or anything other than Program or Stereo 1, I don’t hear anything although I can see midi activity on the Midi track when I play keyboard; but Halion track (under VST Instruments) doesn’t show any activity when I play a note on the keyboard; if change Out to Program or Stereo 1, everything is fine. This has frustrated me a lot. I know solution is probably simple, but WHAT? I will really appreciate any help.

Cubase SX5
Halion 3
Win 7


Make sure you have enabled the outputs in the Instrument Rack. By default, only the first output is enabled. It is a symbol that looks like ->]

JASLAN, thanks a LOT, LOT AND LOT again; after having spent a zillion frustrating hours trying to solve the problem on my own, installing/reinstalling Halion again and again, I finally decided to try my luck with this Forum and it HELPED!!! arooj

Glad to help.

Imagine if H5 could automatically just open up a fresh Cubase channel and activate it for instant signal pass thru, how many hours of new user confusion would be saved, and also how many users would be instantly taught how connections are set.

I think it is a limitation of the current VST technology. The instrument has no way to tell the host that the output is being used. It just reports at initialization how many total outputs there are. Cubase, by default just activates the first one and has no idea which ones are actually being used. Maybe in a futue version of the VST standard, the use status of the instrument outputs could be changed dynamically.