How to auto launch 32 bit or 64 bit version? [solved]

This has been bothering me for a while, in version 5 as well. I’m on PC Win7.
If I start a session in 64 bit, when I come back later to work on the project If I click on the project icon it opens in the 32 bit version of Nuendo instewd of the 64 bit version, where it was created. So to work on any 64 bit session I have to first launch Nuendo from the Nuendo 64 bit desktop icon, and then open the project from within N64 after the program is open.
I tried associating the file type with the 64 bit version of the program, and it still launches by default with the 32 but version.
Any ideas? Or have you experienced the same issue?
thx

I have a feeling that this is by design. I would have thought that the only way round this is not to have the 32bit version installed.

DG

…could be. I know Fredo spoke about using both 32 and 64 bit versions (in N5, anyway). I assumed he was using the same machine for both, but maybe not?
I’m considering having only N6 64 bit installed, but I haven’t spent enough time with 64 bit to know that I won’t have issues with it.

I think that you’ll just have to accept that you will have to open Nuendo and then load the project. 2 more clicks.

DG

You can change this in the Windows-Explorer, when you click the filename (of the project file (".npr")) with the right mouse-button. This opens a popup-menu. There you click “open with”. This opens a sub-menu. There you click “choose default program” and choose the program you want. If you can’t see the Nuendo-64Bit app there you can search it with the button “Browse”.
That’s it.
Hope this helped.

Thanks. This is one of the first things I did, being very careful to choose the 64 bit version - and it didn’t work! So I did it again to make sure there was no user error, and sure enough, it still opened the 32 bit version. I may have to live with the extra clicks, as I have for some time now, but I thought with a new version it’s time to streamline the workflow a bit. Maybe not.

You can also look in the registry how the association is made.
Call the registry editor (regedit). In HKEY_CLASSES_ROOT look for the extension “.npr”. There you find only one entry. The content of this entry should be “npr_auto_file”. Then you have to search in HKEY_CLASSES_ROOT for the entry “npr_auto_file”. Open this entry and in “npr_auto_file - shell - open - command” you can edit the path of the program.

Thanks I looked for .npr in HKEY_CLASSES_ROOT, but it wasn’t there. NOr was there an entry “npr_auto_file” anywhere in the registry. There was this:

but that was all I could find…

You can delete all entries, including the .npr-entry itself. Before you do this, look at the content when you select the .npr-entry itself. You have to search the entry which is given by the content of the .npr-entry. Delete this entry also. Then in the windows explorer open a .npr file and you will be asked with which application you want to open it. There you can choose n6 x64.

You can delete all entries, including the .npr-entry itself. Before you do this, look at the content when you select the .npr-entry itself. You have to search the entry which is given by the content of the .npr-entry. Delete this entry also. Then in the windows explorer open a .npr file and you will be asked with which application you want to open it. There you can choose n6 x64.

I did all this, and oddly, explorer still refuses to let me choose Nuendo.exe (64 bit version) as the launching app. It will only allow me to choose the 32 bit version of the program. Strange.
Oh, well. Thanks for your help. Enough time spent on this. Back to the work-around.

Solved! This is a Windows 7 issue, not a Nuendo issue per se. Thanks riwe for pointing me in the direction of a registry fix.
In the registry I navigated to HKEY_CLASSES_ROOT\Applications\Nuendo6.exe\shell\open\command

I changed the path to “C:\Program Files\Steinberg\Nuendo6\Nuendo6.exe” %1

…and it worked! Now my default launch app for .npr files is Nuendo 64bit. Whew!