How to avoid dynamics collisions on score

the dynamics in my score seem to be colliding with staffs below. how can i avoid this.

By the looks of things you have a bad combination of page size, staff size and number of staves per system. Either make the page size bigger (Layout Options > Page Setup > Page Size) or reduce the staff size (Layout Options > Page Setup > Space Size - which is responsible for the staff size).

Is that Galley View? If so, there’s a setting in Layout Options for how much space is given to each staff there. (Because it’s not actually laying it out properly in Galley View.)

But if that is Page View, then as Leo says: you’ve just got too much stuff. Make it smaller, or have fewer systems.