How to convert MIDI track to Audio so I can export/mixdown?

I have Cubase LE 1.04. I noticed that when I mixdown/export, the midi tracks are gone. I checked the manual and it says:

MIDI tracks are not included in the mixdown!
To make a complete mixdown containing both MIDI and audio, you first need to record
all your MIDI music to audio tracks (by connecting the outputs of your MIDI instruments
to your audio inputs and recording, as with any other sound source).

I was really surprised to find no instructions on how to do this. Maybe it’s just too obvious and I’m missing something. I tried to do it by creating a new audio track, and trying to align the inputs of it with the midi track I’m trying to convert. There aren’t any settings that seem to match.

Can someone give me a clue on how to do this? thanks.

They’re talking of external MIDI gear. Did you Export using Realtime. TheMIDI tracks are routed to a VSTi, right?

What do you mean by Export using Realtime? The only “Export” I can find is under the File menu. It has 2 options, for MIDI and Audio Mixdown. The MIDI option just gives me a way to save a separate .mid file. The Audio Mixdown offers no options for MIDI. I don’t see anything about “Realtime.”

I’m not sure if the midi track is routed to a VSTi. I’ve been playing with all the settings just to get it to record notes at all. Perhaps these screenshots of the current settings will answer your question.

FYI, as soon as I’m done with this song I’m going to upgrade… I’m hoping some of these struggles will go away at that point. But I can’t leave this song, because it’s nearly done and I have to finish with my current version of Cubase LE.

Thanks so much for your help. You deserve to be listed in the credits of this song :slight_smile:

Take the track MIDI one. First, it appears to be Muted. Second, it’s not routed to a VSTi like lm-7 or Universal Sound Module. Third, it should be set to No Map. Fourth, for drums, channel 10 is needed for drums on a general MIDI plug sometimes.

The Realtime option would be in the Export Audio Mixdown window, not in the file menu.

So, if that track is drums or percussion, choose the lm-7 as the output and change the other settings I mentioned and try an audio mixdown.

Thanks again…

1- yes I know it was muted when I took the screenshot but that is not the problem. sorry for the confusion.

2- so the reason I had those settings is that’s how I got the sound to come out. when I route the track to lm-7, no sound comes out.

3- I tried changing to all your instructions - lm7 as in and out for the track… channel 10… and no map… I get no sound when I play the track and still nothing about Realtime in the Export Audio Mixdown window (shown)

Sooooo… I still have that delay on the midi (moving that “ignoreportfilter” file up one level didn’t fix the delay, and I’m not sure if there’s something else I’m supposed to do after I moved the file?) The real reason I’m trying this is because I thought after I convert it to an audio track, I could slide it over a bit to sync it up.

If you have any more ideas I’m willing to try anything, and very appreciative of your help. If not, my plan is to get the upgrade and mixdown a WAV file of what I have so far and then import that into the new version and add the midi (drums) there. Hoping MIDI will be a bit easier to set up in a newer software version.

Let’s start from the beginning.

In a new, blank project, load the lm-7 in the first slot of the Instrument Rack. I notice you have the percussion set of patches selected, so select those. Add a MIDI track to the project selecting lm-7 as the output of the MIDI track. Don’t worry about the input for now, leave default. Monitor-enable the track and draw an event in the track list. Double click on that event with the Pointer Tool to open the Key Editor. Look to the piano keys to the left. Click on them and hold and run the pointer up and down the keyboard to find which keys the sounds are assigned to. Report back.

Only a few notes on the key editor make sounds. the lowest note is C3. The highest note is A3. Everything above A3 or below C3 is silent.


That’s the only notes the percussion set sounds on in lm-7. Write in some notes in that Key editor, on those notes, set the locators and do an Audio Mixdown. Sound in resulting file?

YOU DID IT! Yes there is sound in the resulting file. Now I have to figure out why that’s not happening in the song I’m working on.

Make sure the notes you entered corrospond to the note range of the VSTi.

Your MIDI timing issue is probably due to the fact LE1 doesn’t have Use System Timestamp which would probably sort it.

The update, with hopeful news…

  1. I created a new MIDI track in the song I’m working on and did a test and the sound was included in the WAV file. YAY!

  2. The lm7 had so few notes (drum sounds) I tried switching to the Universal Sound Module, Program Drums Synth, and No drum map… It seems to work. YAY.

  3. Mysteriously, the delay problem with the timing seems to have been resolved also. I’m not sure, but I just did one test and put a drumbeat on the quarter notes for a few measures, turned on the metronome, and they play in sync. YAY!

All this is great news. I can at least try to finish this song before I upgrade my software and start over on the next song. I’m not positive all this is fixed for good but I’m hopeful.

Thank you VERY MUCH. If this really works, I’m seriously going to list you on the credits, when I make a video to go along with it.


Ok, cool. The timing problem was due to the MIDI device you were trying to use for playback, most likely Windows Wavetable which isn’t for use in Cubase. Anyway, you’re up and running.

Yep, the wavetable synth always has a big delay, it’s really not meant for anything other than playing back midi files in windows media player.

Do you think I’ll be OK with Universal Sound Module, Program: Drums Synth ?