How to create barline for first bar

Hi

The figure below shows the very first line of my music. I have hidden the time signature and used the ‘Invisible clef’
MissingBarline.jpg

How do I get the first bar to start with a barline?

I tried Notations Options --> Barlines --> Systemic barline --> Show for one or more staves

but this doesn’t work.

Any suggestions?
Antoine

I don’t think there’s any setting to allow this. You can fake it by creating a Playing Technique that is a barline and then positioning it as needed.

The option in Notation Options to show a systemic barline for a single staff doesn’t apply to the first system, but will take effect thereafter. The reason it works that way is that when I implemented it, looking at the various handwritten lead sheets I had access to, there seemed to be a convention that only systems after the first were ruled with an initial barline, so I chose to follow those examples. In future we could certainly add a further option to additionally show a systemic barline on the first system too.