How to delete VST instruments from the new rack?

I’ve been through the ‘New Features’ manule and cannot for the life of me figure out how to REMOVE VST instruments from the new rack.

I must be missing something here, right?

In the section where you select which instrument you want, select no instrument which is top of the list.

:astonished: :astonished: :astonished: :astonished: :astonished:

I figured it had to be something simple I was overlooking.

Thanks

Even faster: type in “no” in the search field in the vst plugin chooser window and hit RETURN or ENTER on your keyboard. :smiley:

FWIW, it is that same way you remove instruments from the “old” instrument rack (i.e. select “no instrument”).
:smiley:

The Grumpy Cat approach. I like that!

You would think there would be an elegant solution to this. Something like click and delete?

I am confused… Click the name. Select “No VST Instrument” (at the very top). Done. Well, you do have to confirm it but you can get rid of that if you want.
Is this too hard? It has been this way for quite a while and nobody said it was too hard then.
Am I missing something?

No its not hard. However, if you have a long list of VSTi’s it can be irritating.

Guys I am struggling with this. I’ve been using Cubase for 10 years and now have Version 9. I press F11 to choose a VST. I don’t really like having the VSTs shoing on the right because it’s not helpful, but I guess I’m stuck with that! However, I can’t delete VSTs that I am no longer using.

I’ve read your posts but can’t figure it out. Could someone please help?

I did laugh at this because I too was very confused on how to turn off a VST in the rack, looking for the remove or off button, when there isn’t one. Then I realised… Simply selecting No VST is the solution.

dmorguun… The second post covers it perfectly… You’re also not stuck with the VST’s showing at the right you can turn that off.

Edit: I’ll make it clearer for those still struggling as it is quite hidden… It’s the name of the VST in the VST rack where you click, this will change into a pop up menu, you can now select other VST’s and NO VST, which will get rid of it. It’s not obvious at first as some of us don’t think to click the name this way.

2 Likes

I can’t get this to work :frowning:

If I select other VST’s and NO VST I simply get another additional VST pop up without an instrument, it doesn’t remove the one I don’t want. Any chance someone could do a screen shot of what I need to click?

Note: I have created a more detailed image of my problem in a new thread here because this one is very old: https://www.steinberg.net/forums/viewtopic.php?f=250&t=114886

I am having the exact issue with Cubase 9. You cannot remove a VST instrument out of the rack after it has been added. Cubase please fix, a simple X button would go a long way.

I had the same problem, but have found the solution. You have to do this:
1 click on the name of the VST (which here is “HalionSnc”), and
2. then click No VST

This had me stumped too. Simply uncheck the “Right Zone” box in the screen zone setup.

I followed the same process - to click on the name of the VST within the VST Rack (so clicking on the name of HALin5nc5E) for example. Then a menu comes up to select a different VST, and at the top of that menu there is a selection for No VST. When I do that the HALin5nc5E) does go away. However, the VST square (and number) remains, and in its place are the words “No VST Instrument”.

Is there a way to get rid of the VST square? (and the number within the rack it occupies?

You need to remove the midi channel associated to the removed VST Instrument Rack as well, that is if you want to remove the rectangle with the “No VST Intrument” message

I’m surprised nobody has mentioned that you have to “left click” on the name of the instrument. Intuitively you would right click, but that takes you to a different menu!! :smiley:

by mitchiemasha » Thu Jan 05, 2017 11:43 pm

Thanks, you have the correct, precise and simplest way…I also laughed ,as I could not right click my way to a solution.

thanks

Here’s a bug… if you ‘add’ the “No VST Instrument”, that cannot be removed.