How to direct midi in to only output to selected track?

When I select a track, I would like the midi input from my keyboard to only output to the selected track, instead it appears the midi input is being sent out to all tracks in the project (I’m hearing multiple instruments). I tried setting midi input on all other tracks to disconnected, but this didn’t help. If I manually insert a note in the editor, that works, but if I press a key on the keyboard, it appears it’s sending the note on / off messages to all tracks. How do I prevent this so that pressing a key on the keyboard only goes to the selected track?


Make sure the Record Enable and or the Monitor button is enabled on the selected MIDI track only, please.