How to downlaod the Eng ver. of the sofware instead of Chi?

Only Chinese version could be installed even I reinstall it all over it again…
I have no idea how to use it…indeed I have chosen Eng as the preferred language…


Did you try to delete the preferences of Cubase? See this article, please.

Thanks! I’ve tried to remove the preference but still the Chinese one is reinstalled…

Hi, I’m sorry, I didn’t mean during the installation, but before launch.

Cubase uses the system language for the first time. Then it’s stored, and used until the user changes it. So if the language of your system is Chinese, Cubase should start in Chinese language for the very first time. Then, you should be able to change it in the Preferences, and select preferable language.

I’ve tried the same before launching again, but still showing in chinese…
My system is indeed a chinese one then what should I do for installing an Eng one?

Could you describe your way step-by-step, please?

  1. Open Preferences.
  2. Locate General > Language.
  3. Switch to English. Cubase inform you, you have to restart Cubase.
  4. Click OK. Quit Cubase.
  5. Launch Cubase.
  6. Cubase should start in a new language.

Hi, if I haven’t located wrongly, preference should be in the folder of app data right? I could only find folders named “presets”, “project templates” & “scripts” inside, there’s no “general” or “language”. I tried deleting all the stuff in this folder and reopen cubase but still a Chinese interface is showed.
I’ve also reinstalled over and over again but indeed the instruction dialog is already showing in Chinese…still couldn’t find the way…
Thanks again in advance!


In this article, you can find where is the preferences folder located.

I’ve read this article over and over again too. I’ve got into the correct preference folder, still couldn’t locate GENERAL or LANGUAGE.


“General” and “Language” is in Cubase directly. Open Preferences from File menu (if you are on Windows) or Cubase menu (if you are on Mac).

Thank god!! Finally could locate and change the language, the problem indeed was not knowing the keywords “preferences”, &“general” in Chinese…
Many Thanks!