How to enable ASIO DirectX Full Duplex driver

Today, I migrated Cubase Elements 7 to Windows 8.1 64-bit from Windows 7 32-bit.

I use a very simple but effective recording setup at the moment: a USB mic and my onboard Realtek HDA card, until I have some $ to spend on a UR22 and a decent mic.

Cubase’s devices worked well when it “inherited” the ASIO DirectX Full Duplex Driver after replacing Cubase Elements 6.

I want this driver to record an audio track with a USB microphone; without it, Cubase Device Setup cannot identify it.

For recording of audio tracks with other devices e.g. the Realtek HD audio card, I use the Generic Low Latency ASIO Driver which works very well.

Unfortunately, I have not found a way to make the ASIO DirectX Full Duplex driver work under the clean install of Cubase Elements 7 on Windows 8.1 64-bit.

How do I install and/or register the (32-bit) driver (from the previous Cubase Elements 6 installation):



You can’t use a 32bit driver in a 64bit environment.

ASIO4all might work instead.


Think I found a work-around: I installed Cubase Elements 6 which properly registers the DirectX full duplex driver. After which I uninstalled version 6 and copied the required files back in the Asio folder.

Instead of what all thought: these 32-bits drivers seems to work just fine. I still have to encounter an issue.



You are my Hero! Thanks a lot for sharing this information! I was for hours trying to find a way to get multi-client-asio working on my system, including the vidance tool, which didn’t work for whatever reasons. Also tried to copy the asiodxfd.dll into the Steinberg/Asio folder but that did not suffice.
So i followed your advice and simply installed and uninstalled Cubase 6 64bit and now everything is working again (didn’t even have to manually copy anything around at all as the dll was not deinstalled).

Thanks again!

Same problem here. I need Asio DirectX full duplex driver. I don’t have any copy of Cubase E6 but I still have the cd of Cubase LE 5. Will this still works with LE 5 ? (I’m trying to use Cubase 7). Thanks

EDIT : I tried and it works fine with Cubase LE 5 too. I just installed it on another HD

Same problem here. New PC: Win10, 64 bit. I installed Cubase 8 – but ARGHH! - there was no ASIO DirectX FullDuplex driver. So I did as you suggested: I installed an older version of Cubase (Cubase 6) without running it, copied the ASIO files from Prog files \ Steinberg \ Asio, uninstalled cubase 6, put back the files, reinstalled Cubase 8 – Bingo!
Thank you dpmiddleton