How to export blank midi regions?

Greetings cubasers,

So I’m forced to export midi files quite often and then import them into Logic at another studio. However I can’t get Cubase to not ignore the empty regions of the midi file before the notes come into play. I tried writing some random cc automation in the blank regions (meaning no notes) but Cubase still ignores it…

Is it Cubase skipping the empty/blank regions during export or is it an issue with the import? I was wondering if anyone could provide a workaround.

Impress me wizards!

  • RM


Could you provide a screenshot, please? Cubase exports all regions, where are MIDI data (even CCs). Why (and how) do you want to export an empty region? How it should looks like?

Consider the attached image. If I select track 1 and track 2 together then export the midi data (which results in exporting two midi files), what happens is that once I play back track 1’s individual midi file, there will be a blank region (or silence) before the note hits at bar 15. If I were to select track 1 and export its midi data directly, what would happen during playback (or import into a daw) is that the file would start from bar 15 when the note is introduced, thus with no blank region (or silence) before the note introduction (spanning from bar 0 to 15). It becomes problematic when your midi file is supposed to contain silence before introducing certain notes, and that you’re importing it individually into another project.

The issue persists even if I write some midi cc info in the blank region (ex. cc1 automation but with no notes).

  • RM

Try putting your locators around the section you want to export including the empty bars. Not at DAW to verify, but that’s the first thing I’d try.

Doesn’t work for me!


What is your setup that this results in exciting two MIDI files?

Sorry, meant a single midi file that expands to all selected channels once imported into a DAW.


Could you attach a screenshot of the MIDI > MIDI File settings, please?

I have just tried it here and it works as expected. Even if the MIDI Part started at, it has been exported and imported to Even if only MIDI CCs are in the MIDI Part, the MIDI data is exported.

But did you try writing only CC data until, then some notes after Once you import that file does it still place the beginning of the midi file at, or at the very beginning of the timebar?


Are you aware you are export the Locator Range? But the whole project. So the locators position decide which range is exported.


I have tested this again, with the settings Export Locator Range. Of course, if I set the Range to Bar 3 it does export from bar 3.