How to Export Live Input?


I have an analog mixing desk with some some external instruments.

I want to live input the MAIN OUT of the mixing desk into Cubase and be able to (live) export it as well.

What I’ve done so far:
I’ve already setup my input channel in Cubase to receive the audio from the mixing desk.
The input channel is directly set to my internal Stereo Out of Cubase.
With “Monitor” selected, I can hear my live input along with my internal channels on Stereo Out.
So far so good.

But I only can export all internal channels, not the “monitored” one.

Ist there any solution to get it work?
I want to hear my live input and my internal channels at the same time. but also be able to export it rather than record the input channel before.

Any ideas?


What do you mean exactly by “export” ?
Since external instruments are physical, you have no choice but to play them live and record them on a track.

By “export” I mean File | Export | Audio Mixdown.

Since I can hear my external input on the Stereo Out via “Direct Monitoring” switched on, I was wondering if I could record/export the Setero Out channel with the internal stuff but also with the extern input as well.

Make an external effect, connect the outboard’s output to the retun, no need to connect send. Insert this to an empty track.
And you can treat the track like an internal track, export, freeze and render in place with empty parts are possible.

Yes, you’ll need to do a real-time export

Thank you all so far, but it does not work. :pensive:

While playing, I also can hear the live input on a new “external effect” (as described above) applied to an empty audio track (or group channel). I can hear it on the main Stereo Out. The signal routings works while playing.

But when trying to do a rea-time export, the sound won’t be in the audio file. Only the internal instruments. But never the live input. While exporting,

This is my setup:

I can export the internal instruments as well my external instruments.
But the audio signal from the mixing desk as live input won’t appear in the export.
I also cannot see the meter bridge working on my mixing desk while exporting, only during playback.

If you disable direct monitoring in Cubase and let the track monitor on while exporting? Of course you probably need real time export.

If you have made the external effect takes the input, it should appear on the exported file just like any other external effect. Did you make sure the track is routed to stereo output where you are exporting from and you were monitoring through there, not direct monitoring?

You don’t need to use a direct monitor if you do this method, so the first thing you have to do is turn it off, make an external effect take those inputs as a return, insert it on an audio track and it will work.

Also, the audio track has the external effect instance must not be monitor enabled because audio is not coming from the input, it’s coming into the mixer from the return of the external effect. And no need to worry about real-time/offline export because once you set up external effect, the exporting will be forced to use the real-time anyway.

Yes, I followed your description and

  1. set up a new external effect (MSTR), taking my output of the mixing desk.

  2. Created a new audio track (Audio 01, routet to Cubase MAIN OUT) and inserted the external effect as Insert:

  3. I am able to see and hear the mixing desk coming through the external effect to the audio track, which is routed to the Cubase MAIN OUT. Routing is working! But when I try to export MAIN OUT, the external effect signal is always missing.

I have no idea why.
In this easy example I routed an internal instrument (Prologue) to an external output (which is received by the mixing desk) and then routed back to the main out of the mixing desk, which is then received by the external effect.

Which Cubase version are you using ?
If you only have Elements or lower, the Render-in-Place function is unavailable, and you will need to record your external instruments in real time, that means, playing them live or sending the midi tracks and record on an audio track at the same time.
And, even if you had Artist or Pro, with the Render-in-Place function, you will still need to wait for your instruments to play by themselves, because they are external, you simply cannot use Audio Mixdown and expect your external instruments to create a 3 minutes audio track in under a few seconds, because you are dealing with a real analog audio signal ! You can only do that with the internal instruments (VSTi) since they are digital.

Cubase 11 Pro

Your first post contains the answer :

External (physical) instruments need to be recorded on an audio track.
However, if you have added them as External Instruments in Cubase under Audio Connections, then you can export directly with their own Instrument Tracks (MIDI), but only when you enable Real-Time Export on the Audio Mixdown panel.

This does not work. I want to realtime export everything at the same time (internal and external “live” stuff). I do not want to pre-record the external stuff before (to have an audio track) and then export everything. This are too much steps.

I give up.

Addition: I have some true “external instruments” in Cubase, but some tracks goes directly to an external mixer and then back. Those I want to have in the export, too. Sure, the “external instruments” which are set up in Cubase are in my export. But not the “live input” from the analog mixing desk. See also my first picture of my setup.

Well, I think I have understood what you want to do.
You are doing a real-time mixdown and are playing the other instruments live at the same time ?
You are trying to do the impossible. At least I was expecting you to send MIDI to the instruments by using MIDI Tracks, but this is not even the case.
I gave enough clues for you to understand what you’re not doing right.

Look at my picture again. :slight_smile:

  • The external instruments (synths) are controlled by MIDI via Cubase. They are combined in the mixer and processed externally before going to Cubase.

  • With playback in Cubase, the MIDI plays and so also the external synths. They are sent to Cubase.

  • I can hear them in Cubase on my Cubase MAIN OUT, either on an Input Channel which receives the mixing desk and with Direct Out switchend on, or via the External Insert trick described here.

  • With simple playback, I can hear everything on the MAIN OUT. It is there!

  • But when doing the realtime export (which includes the playback, I thought) on the MAIN OUT, the realtime exported WAV contains only the internal channels, but never the stuff from the mixing desk (live input to Cubase, with those MIDI controlled synthesizers).

So I was wondering, why the realtime export does not work, but the playback does.
It makes no sense.

Can you send the project file ?
There must be something wrong for sure.
I have just tried your exact routing and it works fine for me :

Midi Track > Hardware Synth
Hardware Synth > Mixer
Mixer (main out) > Audio Track
Setting Locators properly + making sure no tracks are muted
Audio Mixdown > Stereo Out + Real-Time Export

Result = Audio file contains my Hardware Synth.

Hello Louis,

If I do it as you described, it works.

Buuuut I have omitted a detail in my setup for the sake of complexity (so that it is not even more incomprehensible), which now probably makes the big difference:

Indeed, I have also set up my external synthesizers in Cubase as such: “External Instrument”.

But there I have led the output out of Cubase and directly fed it into the mixer first.

I.e. the External Instrument (or any other VST insturment, does not matter) is created in Cubase, but the audio goes out first and then comes back to Cubase after the mixer. And then it no longer works with the real-time export.

You can test it by yourself:

  • Take any VST instrument in Cubase and route the track (audio output) outside into the mixer
  • and then back to Cubase again.

Then the following happens during the export:
the VST instrument doesn’t play anymore (there is no change on the level meter on the mixer).

Now I wonder what the problem is or what I can do to make an internal instrument (or an applied external one) first go outside into the mixer and then back again - together with a few other synths in total).

Hi @jeff.ray ,

This is the culprit. When you are exporting an output, all other physical output will be muted. Any internal audio goes to anything but the exporting output won’t appear on your interface’s output.
It’s just like exporting from an audio track where all other tracks are muted, from a group, and so on. That’s how exporting works regardless of external fx or internal.
In your test, I presume the prologue goes to, say, output2, and you want to export from output1. That won’t work, because prologue won’t be calculated, cubase does not consider the instrument has any influence on output1.

So, just try connecting anything that plays regardless of cubase to the external effect return, e.g. youtube output of another PC, TV outs, CD/turntables, any instrument or microphone, and try exporting from the main stereo, render in place with empty parts or freeze, then it will work. (I know it works because I always use these half-connected instances for different use cases.)

In addition, if what you want to do is something like using external mixer as just a mix buffer and bring back the mix to cubase, if that’s the case, consider creating other external effects with opposite setting instead of using physical outputs. I.e. external efx instances connecting only sends. Create as many sends ext. fx as you have DAs and inputs on your mixer, insert them to group channels, route cubase’s audio tracks and instruments to those groups, the signal goes out to the mixer inputs, you do balancing on the mixer and then receive the mixed signal with the ext. efx return instance inserted to master.