How to Export Live Input?

At no moment Jeff is saying that he uses two outputs.
From what I guessed so far in this topic, the mixer seems to be a 2 in / 2 out interface, so there is only one stereo input (the mixer’s Main Out), and one stereo output (Cubase’s return to mixer / speakers).
Yes, I say “guess” because that part is very confuse, it’s more of a guess work, maybe we should’ve asked for this information a bit earlier.

Jeff seems to know what he is doing since that kind of routing isn’t what your average bedroom producer would do.
I don’t think there are additional outputs in his project that goes unnoticed. Or is there ?

(By “average bedroom producer” I mean 13" laptop + cheap 2" speakers, you see what I mean :sweat_smile: )

Looks like he has 2 pairs of outputs and sending the prologue to out2, and trying to export out 1.

If you export only out1, anything goes to out2 is muted I.e not calculated, I think that’s what he is seeing and perfectly matches what he described,
You only need 1 stereo input and 2 stereo outputs to do this, not needing any bigger setup. If only for truly external signal (not testing with prologue in cubase), 1 stereo output is enough.

Anyways, let’s wait for his return. My first advices worked til the half way as the signal goes through the main out. He isnnow only struggling with the exporting, and I can see this last tip fixes the last issue.

Hello @TakashiWatanabe , hello @Louis_R ,

now I got it work. Thank you for your tipps and hints.

Instead of using a Cubase connection setup with inputs and outputs assigned to physical inputs and outputs (which was my idea of everything), I followed Takashis advice and used multiple External FX. .

  • A few External FX only with SEND to route my audio to the mixer,
  • and one single External FX with a RETURN, getting the mixer sum back to Cubase.
  • All channels are routed to the regular stereo output of Cubase (no direct routing to physical channels outside Cubase)

So the mixer is handled like an external effect device.

The SEND is assigned to some Group Channels, so that I can route any instrument to the group and so to the according SEND/mixer channel.

I also have a single Group Channel for my mixer input that receives the RETURN. This way I am able to use the regular output for stuff which does not leave Cubase.

Now everything looks like this:

The only issue is, that when solo-ing an instrument track (which is assigned to a group), I also need to manually solo the according group. But I guess this is the only downside of not working in the box.

Thank you all!


1 Like


Glad it finally started to work for you. But this solo issue suggests that the groups with the send instances are not routed to the master on the VST mixer.
You may feel it is a bit odd since the groups are mixed on the external mixer and then routed back to the master, hence no need to route them in Cubase.
But this is important, especially to eliminate PDC problems and also the solo issue. One final tweak to your set-up is to route all those groups with the send instances to the master with the return instance, in the Cubase mixer as well.

And once you’ve done this, it becomes also possible to bypass the entire external mixer just by bypassing the return instance on the master (send instances passes through incoming signal when there is no return, bypassing the return instance will receive outputs from the groups.). If you align the gain of the external mixer to nominal, you can check how the mixer/mix buffer alters the overall sound. And this is OT but in a lot of cases, mixers/mix buffers are very transparent and you may end up not using them unless overloading the mixer or it has nice EQs and such. GL. :slight_smile:


Forgot to mention that I appreciate you for trying to solve this with me. Cheers, mate.


No problem, I tried by best !

Can we still come back to some points :

This is wrong, I just tested it exactly as you explained :
VST instrument (with recorded midi) > Out 1 (Mixer)
Mixer Main Out > Audio Track (Out 2)
Export > Out 2
The file contains the returning VST audio from the mixer, and the VST meters are moving during the export.
You did something wrong in this simple two tracks routing for sure.

I can’t thank you enough. With the little tweak (SEND groups to Mixer Master group, instead to MAIN OUT) it also works with the solo. The entire behavior is now like “in the box”. Wonderful! Again, many, many thanks for the help!

The final solution is as follows:


Are you sure that the VSTi to the out1 (physical out, not using external efx) is not tied to output2 anyhow, I.e. fix send goes to a FX channel then routed to out1, side chain connected, etc.
Even without external efx, when you export from OUT1, anything goes to OUT2 that is not connected to OUT1 from FX sends, cue, and directo outs are not calculated so you will have no chance of getting it on OUT1 by the return instance.You can easily check this with external meters.

This is really a last extra tip. I would recommend you not to insert the return instance to the final master bus. Instead, make another group, name it like “SubMix”, “{nameOfYourMixer}” or so, insert the return instance here and route all the send groups to this group.

This way, now you can send something you want to “come out” from the mix directly to master, like cymbals, FX, vocal samples, and etc. these signal won’t be coloured by the real mixer, will automatically have different character from others that makes lot easier to stand up from the rest.

Also when you do this, you have to deal with latency. To tackle this, first you temporarily connect the return AD inputs to one of the send instance, and check the ping value. (If you see 0, that’s another problem. If 0, just leave it 0 for now.) This value is the same for all other send instances so copy that to all others then Re-connect the AD input to the return. You don’t have to enter any delay amount to the return instance.

Despite the @Louis_R ‘s test, your hazards were all expected for me, you know it’s easy once you know how but mind bending if I told you at once. :slight_smile:

It may be expected for you, but not for me. What about YOU do the test ? :wink:

My Instrument Track (VSTi) is directly routed to the mixer, then the mixer Main Out goes to an Audio Track which is outputted to the speakers.
During the real-time export, every track that are routed to other output channels than the one selected in Audio Mixdown still send the audio to their corresponding channels, so the mixer is returning the audio as it should.
I’m really having a hard time believing that you cannot reproduce this simple routing.
I’m not even using groups or sends or whatever, so no, the outputs are not “tied” together…

I admit my knowledge around external efx and physical output is old, built in the past decades since we used to mix everything on desks with lots of D/As, thus I know if you export from out A, anything else won’t appear.

So I did the test again as you requested, a minimized version doesn’t even require external efx.

  1. make 2 outputs in the F4 panel - out1 (da 1&2) & out2 (da 3&4)
  2. insert a testtone generator on the output channel of out2 → you will see continuous activity on your audio interface output meters 3 & 4.
  3. realtime export from out1
  4. watch meters on the audio interface.

If you do this, the testtone generator does not output to the audio interface’s 3 & 4 during the export, i.e. no meter activity on the interface or anything connected to it.

As I said earlier, as long as the signal goes to out2 (3&4) is not connected to out1 (1&2) by any route, I believe cubase/nuendo won’t calculate the needless path on the real-time export. (as well as offline export presumably. In this case, everything is done internally so we never realize.)

Jeez… how hard is that to reproduce exactly what I’ve done ?
I’m a not telling to put the TestGenerator plugin, as this EXACT plugin will cut out automatically during export… Just create an Instrument Track with a VST of your choice, write some midi notes and export. Damn.

Okay so I did it two times earlier and it worked fine, then now it doesn’t work anymore. I swear.

OK I did it again.
And the result was the same except I could see meter activity on the VST mixer but not on the audio interface’s output meter.
So my assumption about calculation was false, but still, the output is cut.

And this gave me an idea. Which VSTi did you use for the test? I made sure to use one with a single output. Maybe I’ll test again with multi-out ones and set the main out to go out from the second pair.

--update-- I tested again with halion6, 2 outputs enabled, 1 goes to out1, 2 to out2, play a note on out2, receive it on an audio track with an external efx, exported out1. Same result. Out2 is cut during real-time export. Same result on exporting from the audio track.

I don’t know why you are seeing a different result, but Jeff’s result is the same as mine, so there must be something different in your set-up.

Again the point is, if you realtime export from out 1, nothing will be output on others. It’s been like that for decades.

I swear it was working when I did it previously, and now I can’t manage to reproduce. That may just be a mistake from my part. I feel bad lol, please forgive me.

1 Like

No need to worry at all! It’s really complicated and easy to miss.
It was a good opportunity to update our knowledge anyway, was also a nice time talking to you (again), cheers. :slight_smile:

1 Like