How to find and install Cubase ASIO driver?

Greetings. New to the UR44C and Cubase.
Used Audacity a decade or more back. Cubase is … trickier.

I know that the UR44C works, because I plugged it into my android tablet and used Open Camera to record a video w/ stereo mic input.

So, I’ve installed Cubase on my Win10 laptop. I see that it’s using a generic ASIO driver. I recall reading that there was a better steinberg/Cubase driver that I thought I’d made available as part of the installation process, but I guess not.

I’m assuming that it’s on the laptop somewhere; how do I find it and install it? The online help refers to what’s shown below, but where do I access Devices? (I tried the Windows Device Manager; I can see two UR44C audio inputs, and I likely can specify the driver to use, but I don’t know in what directory it resides.)

Any & all assistance welcome.

  1. Select Devices > Devices Setup.
  2. In the Devices list, select VST Audio System.
  3. Open the ASIO Driver pop-up menu and select your audio hardware driver.
  4. Click OK.

The ASIO driver you’re looking for is unique to your audio interface. If you don’t see it in the Devices Setup, you likely have not installed it.
I do not own a Steinberg interface, but it seems you need “Tools for UR-C” that can be found here:

Thanks very much.

My question – where is the ‘Devices Setup’? Is it a separate program?

Sorry, “Studio Setup”.

1 Like

Thanks again. And I think I might have found the .dll:

C:\Program Files (x86)\Yamaha\Yamaha Steinberg USB Driver\ysusb_asio64.dll

If the ASIO driver of your device does not show up in Studio Setup, the installation has likely not been successful. Finding the .dll is not going to help.
If you already tried re-installing it and it still does not work, I would try installing as an admin.
Hopefully someone who is more knowledgeable about the UR-C interfaces will chime in if the above does not work.

1 Like

Is the interface in the wrong mode? If it worked with the tablet then it sounds like you have it in class compliant mode. I don’t have one so check the manual for this. I know my zoom interface has a switch for this and my rme interface has a boot sequence

I’m aware that the UR44 had a Class Compliant switch, but the UR44C does not, and there is no reference to Class Compliant in the manual. I’m guessing that the switching in the 44C is automagic.