How to get Cubase to receive my left pedal press?


While Cubase LE AI Elements 9 does not require any prior tweaks to register the right pedal of my synth (Yamaha CVP-79A), I can’t get it to register the ‘softening’ commands of the left pedal - the recorded/played back audio is totally unaffected no matter how hard I stomp. :slight_smile:
Here are the settings of my Yamaha CVP-79A:
Left pedal -> soft.
Send CH ->Basic 1, Left/2-> OFF, Local->ON, Clock->Int.
Send&Receive (for each item)

Thanks for your comments.

Midi spec for my Yamaha says CC#67 for soft pedal.
Check if that is present in your recording?

Then check setting for send and receive for midi on Yamaha settings.
As I recall there are various for settings for different categories midi stuff.

Also I have various modes for midi port channels - if they are for songs, R1, R2 L meaning righthand 1 and 2 and left hand, or full keyboard.
So having Local off - you should hear what it respond to - or not.

Midi monitor plugin may also be helpful to see directly what is sent.

Hi Larioso,

Thanks for your comments.

I wish I knew how to do it. How and where can I do this check? :confused:

I’ve noticed that the loaded VST (Halion Sonic SE2) actually responds to the pressing of the left pedal - 2 indicators flash simultaneously (please have a look at the pic attached). But the SW sound stays unaffected, compared to the HW sound of my Yamaha when the left pedal is pressed.


are you sure that the synth you’ve got (HSE2) actually uses Soft pedal, ie: does it have soft pedal samples or incorporate some sort of EQ for Soft pedal? Doesn’t do much for me - Sostenuto it does but Soft I dont think so. That could be the prob.

Anyway, dont know that specific keyboard, but as the man says, you may try turning LOCAL OFF, in case it’s sending the controller messages to the onboard synth somehow instead of Cubase.

Likely though, Larioso’s suggestion of checking the MIDI monitor should help - open up a midi track on cubase, set the input to the keyboard as normal (see if its communicating notes etc) and then in a slot on the MIDI INSERTS rack in the inspector - load up MIDI MONITOR - you should be able to see then if the pedal is registering in Cubase and what midi controller message its actually sending out.

Here’s a pic! you can see the MIDI page for HSE2 and the CTRL subpage - just check none of the filter switches are lit up, i.e. HSE2 is not filtering out the pedal messages

and you can see the pedal number register in the midi monitor, when I pressed the Sustain pedal it registers 64, so presumably yours should register 67 for Soft. If that’s all working fine then, its probably just the limitations of HSE2. It doesn’t have the legs.

Now, if you were using something like Ivory, you’d have soft pedal samples built in, so it plays them back when you press the Soft Pedal. Mmmm, Ivory ;o)


Hi Dan,

Thanks for your comments.

I’m absolutely not. Anyway, I need to find the way to register the soft pedal with Halion - I guess Halion is capable of handling such tasks.

I’ve already tried to no avail.

I’d love to, but how can I make ‘MIDI inserts’ available on the Inspector menu?! I have ‘Audio inserts’ and ‘MIDI modifiers only’ - please have a look at the screenshot. This item is unavailable on Setup Inspector menu as well…

I’ll give it a try although I don’t know what you are talking about. I’ll google the name at least. :slight_smile:


seems not supported in AI********

thanks planar

Cubase Elements sadly does not have the MIDI Inserts feature or indeed List Editor. Should be able to use Key Editor as suggested above though. It may be that the Lane for the Soft Pedal is hidden so once you’ve got the Key Editor open you may have to click on the triangle on the left of which ever Lane is showing (Velocity probably) and add #67.

Hi planarchist,

Thanks for your comment.

I managed to expose the recorded ‘track’ of the soft pedal by following your suggestion (pic attached), but the problem is that the ‘softened’ parts are still played back as if they’d been recorded without applying the left pedal… :confused:

Unless you have applied a message filter in CuBase preferences (I.E. Set it filter the CC the pedal sends), All versions of Cubase will faithfully record and play back any messages coming into a track.

For the soft pedal to work, the instrument it is connected to must actually have a soft-pedal implementation. For instance, not every piano patch for every plugin knows a ‘soft pedal’ even exists. So, you could send it CC messages all day…if the instrument doesn’t know what to do with them then nothing is going to happen.

Having said that, specifically what plugin/instrument are you trying to get a soft-pedal effect from?

If I have it here I’ll load it up and have a look to see if it supports a soft pedal, and what CC it expects to receive it over. If the patch doesn’t support it natively, and if it’s possible to provide a work-around to emulate the effect, I’ll share that as well.

…I tend to agree with Brian here, are you sure the plugin you’re using supports a soft pedal message?

Hi Brian,

Thanks for your comments.

I do agree on the record part, but I’m not so sure on the playback… No filters have been activated, please have a look at the screenshot.

HALion Sonic SE, upgraded from 2 to 3, but to no avail in terms of the soft pedal. The instrument is Acoustic Grand Piano.

How can I find out whether or not HALion Sonic SE supports the PLAYBACK of the left pedal commands?!?

paulxoro, I don’t think that particular piano does soft-pedal. A damped piano isn’t part of the GM1 requirements, and that’s a very general Piano patch. I’ll double check as soon as I can and follow up here.

The good news is that I’d imagine we could either find a better piano from your available choices that does it, or emulate the effect to some degree.

If I can’t find an alternative patch that does soft-pedaling, we can probably build something that stomping a pedal will give you a dampened effect there.

As for how to find out, that’s not quite as easy on SE as it is in big brother “HALion 6”, where we can look a little deeper into the presets and adapt them with personal tweaks. To find out in SE, about all you can do is stomp the pedal and see if it works…you might try different CCs between 65 and 69 (those are all various pedal types in the GM specifications), but other than that there’s no easy way to visually check or tweak anything outside the macro screen in SE.

Here I stand abandoned and forgotten… :frowning:

Sorry…life got busy and I’ve barely fired up the tracking DAW in months, plus I lost track of making this promise. Other than making/fixing scores in notation packages, I typically don’t get to work much with ‘computer music’ until December or later.

At this time, I’m not aware of a patch that comes with CuBase and HALion SE that supports the soft pedal.
It should be possible to build something that can emulate the effect to some degree.

Off the top of my head, I’d say use a local input transformer to change a CC67@127 event into a ‘reduce CC7 by X-percentage’, and CC67@0 into a ‘increase CC7 by X-percentage’. This would at least cause the volume to change with the pedal. You might also right click some of the filters or tone knobs for the pinao patch in HALion and assign a CC there as well, and add this to the transformer.

Another approach might be to load up multiple pianos on different channels, tweak out one to be the ‘soft pedaled’ piano, and the other to be the ‘louder/default piano’. Again, you’d use the ‘local track transformer’ to handle changing the channel when a CC67 event comes through. So, pedal down would change the MIDI channel (on a MIDI or Instrument track set to channel ‘any’) to use the soft pedaled patch, and pedal up would bounce back to the channel holding the default piano. This approach would give you much more control over the sound and tonal quality of both pedal positions.

With HALion 6, it’s also possible to go in and make it properly interpret a soft pedal event. I might could build a patch preset for you that will work in SE, but I’m not sure when I’ll get the time.

Hi Brian,

Thanks for your reply and advice. Input Transformer seems to be NOT available in Cubase Elements 9 (see the sreenshots)… :cry: We are sort of second-class users. :laughing: ‘Man, stomping the left pedal is not your prerogative!’
I’m just suprised to find out that Steinberg won’t consider this feature essential for any piano player. On the other hand, one would not be willing to throw away two hundred bucks for an upgrade which sole aim is to make the soft piano play dempened notes, would he? :confused:

Interesting, I didn’t realize that a local transformer per track was Pro/Artist only. I thought it was only the ‘insert effect’ variant of transformer that you didn’t get in Elements. Oh well…

I’m about to head to work, hopefully I’ll remember to come back and see about exploring some alternative piano plugins with you (that have more robust pedaling support). There might be some free or really inexpensive ones out there that are as good or better than what comes with CuBase Elements.


I just thought to ask…
Do you get a transformer with MIDI tracks (as opposed to instrument tracks)?

If so, when you need to do transformations try loading Halion as a ‘rack instrument’ and use MIDI tracks instead of instrument tracks. It’s also possible to direct the output MIDI tracks to a plugin loaded in an instrument track.

If you grab the sforzando plugin, you can also get some free sounds that include some decent pianos. I’m not sure if they do soft pedal but it’s worth a try.

Brian, no this feature is unavailable for both MIDI and instrument tracks in Elements 9. (I have attached two combined screenshots in my previous reply).

Thanks, I’ll check it out.