How to get this macro working


I want to split different snares from one audiofile.
So i came up with the following macro,

  • Hitpoints - create slices from hitpoints
  • Dissolve part
  • Edit - Set spacer between selected events
  • Render in place

The problem is, it stops after hitpoints. I have to activate it again to go to the next.
I also wish the spacer menu doesn’t show because i never adjust the setting.

Is there a fix, or a easier way to split audio?

Thanks in advance!

I think the chain of commands is fine. But getting it to work in a macro, that’s going to be tough, because Cubase does not wait for each action to finish before it gets to the next one.

this is because the region is not automatically selected.
I would do it this way:

  • Hitpoints - Divide Audio events at hitpoints
  • Render in place

without the spacer it’s being renderd as one part, also if i don’t disolve the part.

Thats too bad, thanks for the info!

Thanks for the effort! I recreated your macro path, but i stumbled into this problem. Its not slicing correctly like in your vid.

If you use Metagrid, you can insert user-created pauses of your choice between commands. I know that’s probably not your solution, however if you are developing a lot of macros, especially with PLE and LE with your macros, Metagrid may be something of interest for you. You need an iPad, but you can use a very old version so it’s not necessarily expensive. Also, you will never use your keyboard for key commands again except for the very basic commands.

Oh man, I have no idea :confused:


My workaround is too put the Save function as “wait”. Cubase stops all processes while Save and then continues. So you can do:

  • Step 1
  • Save (wait simulation)
  • Step 2
  • Save (wait simulation)
  • Step 3
1 Like

I forgot to put the disable tail mode, that was creating this problem. Thanks again!

1 Like