how to make key chnage notes not follow chord track ?

whenever i have a track following chord track, all the notes follow, even the key change notes. how can i make key chnage notes not follow chord track without creating new track for key chnage notes ??

I’m not really sure what you mean by 'key change notes", but in general, turn off the follow chord track function. It’s sole purpose in life is to force notes to be in either the current chord or key. If you want to have notes other than those, you need to turn it off.

If you are using key-switches to change articulations, programs etc. then create an expression map with those in it and use the controller lane to invoke them. Even though the map will generate a midi note, it is not listening to the chord track and won’t move the note to be in the chord/key.