How to make more space for chord symbols

In the attached images, the chord symbols are packed together just a little too tightly for my taste: bars 7-9 in image 1 and bars 15 and 17 in image 2. (Notes have been ‘zeroed out’ and chord roots randomized for copyright reasons.)

If I were doing these charts by hand, I’d probably slightly reduce the size of the spaces shown in the empty rectangles to make the bars with more chord symbols wider.

In Dorico, my first thought was to manually do that by dragging things around in Engrave mode > Note Spacing.

I could also try changing the Note Spacing settings in Layout Options, but I’m concerned about the 16th notes getting too close.

What’s the best way to deal with this?

Dorico-note-spacing-1

Dorico-note-spacing-2

Try increasing Engraving Options > Spacing Gaps > Minimum distance between adjacent rhythmic items. It’s a scarily global setting but I’m pretty sure it’s all we’ve got (aside from adjusting them all manually).

1 Like

That helped!

Default was 1/4. I haven’t decided whether to use 3/4 or 7/8, but one of them will work (and manual adjustment of note spacing will almost certainly be unnecessary).

At 7/8, I had to use “make into system” in a couple places to prevent undesired system breaks, but I didn’t see any problem with this.

Toggling between the two PDFs in the Mac Finder, it’s interesting to see the [many] changes Dorico makes.

Thanks, @pianoleo !

You might try compensating by setting the first value in Layout Options > Note Spacing to something slightly smaller - that might help.

What would that compensate for?

I just fiddled with it a bit, and I don’t yet understand what I was seeing! At first glance, it seemed that when I reduced that value, the notes spread out further. I’m probably missing something, but the results seem counter-intuitive…

In the unlikely event that you’re writing in open meter, you’ll see that the lower the number (default space for a quarter note) the less space between notes. The thing that’s counterintuitive is that in metered music we tend to do only allow systems to break at barlines, so if you only reduce the number a little way you’ll probably just see Dorico apply the (unused) space in a different way. You need to lower the number far enough that Dorico feels it has room to squish a whole extra bar onto the system.

1 Like

The piece is in 4/4.

I removed the extra system breaks and gradually changed the quarter note spacing. At 3 spaces, Dorico automatically makes all but one system breaks where I want them (the exception is a two-bar coda at the end).

But again, when I toggle between PDFs in the Finder, it seems as if some bars are wider in the version with smaller note spacing, and it doesn’t seem to improve the bars with more chord symbols.

I’m confused!

1 Like

While increasing the spacing gaps put more space between chord symbols, which I wanted, changing note spacing didn’t help with the problem of too much space after the half notes, especially in bars 24-25 in the image below (from the same song). It reduced that space a little, but it brought other notes too close together.

I’d like bars 24 and 25 to be wider. Each chord lasts for two beats, so I’d like each symbol to occupy half to the horizontal space of the bar.

I tried moving the triplets in bars 22 and 23 to the left graphically (via the circular handles). Then I moved the bar lines at the end of those bars to the left. But since bar lines don’t have circular handles, these adjustments changed the note spacing. I thought it looked worse.

Feature request: I’d like to have circular handles for individual bar lines.

EDIT: As a work-around, I added four quarter notes to voice 2 in bars 24 and 25 and hid them by setting the custom scale property to 1%, as in the second screen shot. Much better!

Dorico-note-spacing-3