How to manage rests?

So I have a score with a bunch of different instruments. The things I wonder about occurs in the different instrument parts. Two things:

  • Dorico automatically displays a “1” when there is one bar rest. This is stupid. How do I remove that?
  • When there is chords written in the score Dorico displays every bar in a part of an 8-bar rest. This is also stupid. Can I get rid of that?

THANK YOU! I really like Dorico. But sometimes things aren’t the way you hoped for.

The one-bar rest thing is an Engraving Option. Engraving Options > Rests > Multi-bar rests > Bar count for single bar rests > No bar count.

For the chords, in the part layout select the chords you don’t want to see and set their Hide property in the properties panel. Dorico should then consolidate those bars as multi-bar rests (assuming that’s what’s set at Layout Options > Players > Bar Rests and Multi-bar Rests). There are other ways to go about this, such as turning off chord symbols for that player and then using Chord Symbol Regions specifically where you want them, if it happens to be a player that doesn’t need to see all the chord symbols.

Generally speaking Dorico’s highly customisable. If you think something’s stupid, change the options. For that matter, make use of the Save As Default buttons in the bottom left corners of the options dialogs - chances are, if you don’t want one-bar rest counts in this project, you won’t want them in the next project either.

Thanks for a great answer! Yes, I know, that’s one of the reasons I love Dorico. Really do! Just got irritated about these things, which I consider an odd “standard” way to show rests. But there might be times when it’s good too so! I’m happy with Dorico. Especially since it comes with probably the best forum I’ve encountered.

Thanks again!

And hey, another one:

If there’s a section with 8 bars rest, Dorico shows the first bar if there is text written on it. Can I in some way make Dorico display it as a multibar rest of 8 instead of 1 + 7 as it does now?

Only by ensuring that the text is attached to the downbeat of the bar (in Write mode). If the text is midway through the bar it’ll split the multi-bar rest.

Ah. I get an engraving problem when I attach it in the start, because I also have a rehearsal mark there so the text and the mark takes up a lot of space. I decided to move the text which made all the parts look better. But I guess I might need to set the text in the start of the bar and then manually fix the engraving?

Precisely. You may find that it makes life easier if you set the text’s “Avoids Collisions” property (by which I mean turn it on then untick the box) - this way it won’t create extra space. Then drag the text in Engrave mode so that it clears the rehearsal mark. If you do this with the “Set local properties locally/globally” switch set to “global” then it’ll update the position in all layouts (for better or worse!).

I only find “border” as a property?

You’ll notice properties differ while in write or Engrave mode. Avoid collisions must be visible in Engrave mode only.

Ah perfect! Thanks chief.

One last. Where do I find that?

It’s at the top right edge of the properties panel.

I find avoid collisions and border thickness there…?

What version of Dorico are you running? It was added in Dorico 3.5. In earlier versions, I guess you could move the text, then, still in Engrave mode, still with the text selected, go Edit > Propagate Properties. I think that’ll move it everywhere but don’t hold me to that - it’s a good while since I used an earlier version than 3.5…

Here’s info about the Properties panel in 3.5 and this is a comparison of local vs global properties. In earlier versions of Dorico (from v2 I believe) you can Propagate Properties to copy the state of properties set on selected items to other layouts.

Well that explains it. I have 3.1 so.

Thanks for all the help! Invaluable!