How to move systems between frames

Hi there
Is there an easy way to move systems between pages or frames? What typically happens is that a song layout will end up running over two pages, with large spaces between systems. I can’t work out how to bring the systems from the second page onto the first page once I’ve narrowed the spaces between systems so it should all fit on one page. There doesn’t seem to be any system break stopping them moving over, and it doesn’t work if I cut and copy from the second page back to the first. I’m obviously missing something!?

It would be useful to see an image of exactly what’s going on, but:

If you have a page with two systems, one at the top and the other at the bottom, with a large space between them, then you need to change your Vertical Justification Settings in Layout Options.

I’d suggest reducing the first % number to 50%, and see if that improves things.

You’re doing too much. Don’t manually squash things up. That will just… well, … squash the existing systems up. Use “Make Into Frame” in Engrave mode to select the start and end of the music that you want within one frame.

Alternatively, you could change the Note Spacing in Layout Options, – go down from 4 to 3.5 – which will space the music a bit more tightly, and maybe result in fewer systems overall. You may need to find a value that gives you a good balance (particularly the last system), and is not too cramped.

Could you explain more about how to ‘Use “Make Into Frame” in Engrave mode to select the start and end of the music that you want within one frame’. I had tried that but it didn’t seem to work. How do you select the start and end?
Here’s a picture:
Dorico screenshot.pdf (152.1 KB)

Shift-click doesn’t work but try Cmd/Ctrl-click the second object.


1 Like

For what you’ve shown, I would do two things:

Layout Options > Note Spacing.

De-select “Only Justify final system in flow…”

As said earlier, reduce the note spacing slightly, to see if that gets you fewer systems.

The other thing you could do is in Vertical Spacing – reduce the Inter-system gap to a slightly smaller (integer) value.

“Options first, then Manual adjustments.”

I shouldn’t need to reduce note spacing, as there is plenty of room on the first page for 2 extra systems at the bottom, with the vertical spacing reduced.
As I say, if I reduce the vertical spacing on page 1, the page 2 systems still stay on page 2. I’ve tried moving the page 2 bars to the previous system, and that gets them onto page 1 - except they’re all squashed up on the bottom system. If I try and move them to the next system, they bounce back onto page 2.
I’d really appreciate a step-by-step explanation for the ‘Make into Frame’ function, and if that would apply here, thanks

Sounds like you already have a Frame Break.

That sounds like you’re using System Breaks. That won’t work – you’re just adding bar to systems, not systems to frames.

Make into Frame is analogous to Make into System, but instead of fixing the bars into one line, you’re fixing the systems into the frame/page.

If you’ve moved systems closer together manually by moving them in Engrave mode using the Staff Spacing tool, this won’t prompt Dorico to recalculate the casting off and bring systems on the next page back. The Staff Spacing tool in Engrave mode is really intended for little tweaks once systems are on their intended pages.

The better way to prompt a recalculation is to adjust your vertical spacing settings for the layout. Set the Ideal Gaps to the smallest value that will work in this layout, and let Dorico add any extra space needed to notations outside the staff, high/low notes etc. (E.g. try lowering the Ideal Gaps and slightly increasing the Minimum Gaps between staves/systems with protruding items.)

If changing settings still doesn’t get the result you want, you can use Make into frame to force music onto the same page.

OK thanks everyone - I finally found the correct vertical spacing setting in Layout - it all makes sense now!

1 Like