How to not break a midi recording when deactivating a tempo track done with timewarp ?

Hello,

need some help from the communauty :slight_smile: !

I’m doing lot of tunes with the Timewarp feature. so i have a tempo map who change at each bar, sometimes at teach beat.

Drums (Vdrums), bass, keyboards, guitars, lead, all of them are recorded with this tempo maps. I use it for different purpose, for example to do a cover which follow the exact same tempo than the original tune.

unfortunatly, when i deactivate the tempo and i want that the song has a fixed tempo, all the midi notes are… well the song is broke, and the notes are not in a correct rythm anymore. I know there is this stuff called linear and musical mode, for tracks, something like that, i don’t know if it’s related too…
let’s say that with a tempo map, i have a drum track which plays but with a tempo change on each bar, if i’m going back to a fixed tempo, all the recording is not usable anymore.

is there a way, or a tip, so this will not happen ? and so a drum track on a tempo track which change a lot, once back to a fixed tempo, well, stay on the beat where it has been quantized (that’s an example) and not a messy of note ? same for the other tracks ?

If you have the time base for the tracks set to ‘Musical Mode’ do you still get the same issues? I’ve just quickly tried here and it seems to works fine.

I’ve attached screenshots where the tempo track is enabled & disabled and the MIDI events are unchanged.

Hope that helps!

Rich


Hi thank you very much, i think i understood the mistake but don’t know how to not make the issue :smiley:
i’m certainly doing something wrong, but just don’t know how to not do the mistake.

I just checked what you told, and it work fine, on a Midi or instrument track ! (thanks !)

usually, when i’m doing a map tempo using the timewarp feature on the projet window, i do it on an AUDIO track, as i want the tempo map to follow the original version of the tune. when i do this, the time base of the audio track goes to linear but put all the others tracks in linear mode too.

so when doing it on the audio track, it’s not only the audio track which stay in linear, but the whole project, all the tracks (midi / instruments) goes in Linear mode ! so when i was doing this, i was putting back all the tracks to musical mode when i finished the map tempo edit.

i think i maybe do a mistake here and i’m maybe not doing it properly ??