How to Output Hairpins/Crescendos to CC1?

I have created a sketch expression map for my VSL Dimension Brass as a test to see whether the playback techniques are accurately outputted to the CC data. I am able to trigger the legato articulation, for example, but when I use the volume dynamic to CC1, I don’t see the crescendos reflected in the lines, though I do see the ppp, f, fff shown.

How do you get Dorico to output hairpins to CC data?

Your screenshot doesn’t provide quite enough context to really see what’s going on, but I wonder whether you’re possibly looking at a different instrument in the Key Editor than you are in the notation, or whether you’ve not assigned the expression map in the Endpoint Setup dialog?

OK I will send three more pics. First shows that I am looking at the correct track in the MIDI area. Second shows the Expression Map setup for the track. Third shows the actual expression map dialog box. LMK if you need anything else.

Try changing the main Volume dynamic control above the bit you’ve circled in your screenshot of the expression map to the appropriate MIDI controller. You’ve only set the secondary dynamic control.

No dice. The swell shows up in the dynamics tab of the automation but not in the CC1 which I have assigned it to. Also, what’s the point of showing the dynamics tab if it’s not attached to any CC channel?

I’d suggest you attach the actual project so I can take a look at it. Pictures will only take us so far. Here are our guidelines for how best to ask for help here on the forum:

I think you might need to have crossfade engaged on the VSL instrument, and the cc pointed to the crossfade cc specified there. Sometimes it’s 1, and sometimes it’s 2.

It is engaged. And when I manually draw in the automation points on the MIDI lane in Dorico I can see the fader moving up and down.

Arlington (JFK) v07.dorico (1.7 MB)

Thanks for attaching your project. You haven’t defined a Natural switch in your expression map. Define a switch for Natural and set the Volume dynamic setting to Control change with a value of 1 and that should sort it.

Yep that’s it! Thank you. It still should work when I am using the legato articulation, though, right? In any case, problem solved.