How to record audio from digital piano onto Cubase?

hi guys

I’ve got a roland hp 3700 digital piano. I’ve connected the stereo outputs from the piano to the inputs of my soundcard, which is a focusrite 6 USB. I’ve opened up my cubase 5 and I’m trying to get the audio playing from my own piano (i.e. the sound from the piano itself) to be recorded in Cubase. I used to do this on older versions, but when I go to the Device Setup under the ‘Vst Audio System’ the inputs are showing as inactive?! And so I’m unable to record the sound from the piano coming out onto Cubase.

Any ideas or pointers would be great.

Thank you

Aloha Y,

‘Vst Audio System’

I’m on a Mac so our systems differ but did you try
going to VST Connections?

Once there, clik the ‘input’ tab and see if your soundcard
shows up.

had a 3700 way back in the day.
Loved it. Had to sell it when I moved here.


I can see you are using ASIO DirectX driver. DO NOT! It may (or may not) be source of your problem, but anyway you should use your sound card’s native ASIO driver.

Inactive ports are due to not connestced busses…


And on the screenshot I can see there’s a MIDI track record-enabled in Cubase. You should create an Audio track instead.

Ha, thank you for the responses. Yes, the HP 3700 is awesome:)

I will try the suggested tonight and post back.

guys, it worked!:). It was the VST connections. I deleted what was in there and added another new one and presto…works.

I also used the Asio driver from the soundcard instead. Perfect:).

Thank you

just curious how you hooked up the front connectors on the focusrite. as the sales guy at a certain place was coy with the specs… to get stereo from 1/4 jacks… I had to use both connectors…OR you only get mono if you use 1.

Yes that’s true.
Because audio interfaces 99% of the time have balanced inputs, you can’t use them as stereo inputs because all the connectors on a jack are already in use for a mono signal :wink:.
Look up balanced audio signals for some more info, you’ll see why a stereo cable/connector can’t carry a stereo signal if it’s balanced.