How to record Tone Generator to an audio track

I know this has been done to death on the internet, but not one of the instructions or videos that I watched worked. I am using Cubase 12.0.40 on Windows 11. Can somebody give me a simple list of steps to achieve this? No matter what I do, if I send the output of an audio track with the Test Generator as in insert to a group track, no audio track I make is able to see the group track as an input. I am missing something very fundamental. Is there some issue with this in Cubase 12?

I am half aware that there is something about avoiding feedback loops to be able to do this, but I don’t grasp that yet.

Hi Andro,
This is fairly easy, and there are multiple ways to do it. However you don’t say which Cubase tier you are using, this is quite important because some ways can only be achieved on higher tiers (Render in Place is on Artist and Pro, an Direct Routing is only on Pro).

Here is the list :

  1. Set the Locators where you want to render, Solo your TestGenerator track, then use Export / Audio Mixdown. You can also set After Export to Create New Track so that the Render is directly added to the project.

  2. (Artist and Pro) Create an empty Part on the track by holding Alt and dragging your pointer, then Ctrl + Right-Click on the Part to open the contextual menu and select Render in Place (open settings and choose “Channel Settings” so that the inserted TestGenerator is included in the render).

  3. (Pro) This is what you explained in your post with the Group, but this requires Direct Routing, that’s why it doesn’t appear in the Input list.
    Alternatively, instead of using a Group, you could create a dummy Output Channel in Audio Connections and call it “Record” or whatever you want, but don’t connect it to any physical output, remove them if it connects automatically. This should just act as a dummy output.
    Create a new audio track so you both have the TestGenerator track and the “record” track.
    On the TestGenerator track, select your dummy output as the Output, and on the other track, select it as the Input. Now the dummy track can record anything that is routed to it, and there’s no feedback loop involved, this is completely safe.

1 Like

+1 for option 2 if you have artist or pro.

Yes I was aware of the difference between Artist and Pro. I have Cubase Pro. I forgot to mention.

@Louis_R No 3. works using a dummy output. When I record, the tone is laid down. but I can’t for the life of me get the input of the audio record track to be anything other than ‘No Source’ So if the input is ‘No Source’ how does anything get recorded, and why does my experience differ from your clear instructions? Why does the fader show no level?

Andro, I think Louis is saying that you have a source audio track with the tone, a dummy output with no output connected, and a second audio track for recording. It’s that second audio track where you select the dummy output as the input.

In Nuendo it works as I think Louis described it.

Note that you can also use a tone generator on a Group or FX track, and those should show up as available inputs on your audio track - which means no need for a dummy output.

1 Like

Nuendo or Cubase is the same, just make sure the output bus has no physical output connected to it.

Although it seems to be quite buggy after each Cubase restart, sometimes it will show no level on the meter like you said, and even the Monitor will not work, it will just record silence, in which case you have to select a different output on the record track. Just changing the output is enough to fix it, you can then select the original output again.

I don’t know either how it can record if no input is selected, that’s a mystery.

Also if the output doesn’t show up, it means that doing so would cause a feedback loop.

dummy output

dummy record

The easiest way would be to add the generator to an input channel insert and record it.

Or as I said a group or fx track. But either way it’s one track less than using a dummy output… not that there’s anything wrong with that.