How to remove extra space from beginning and end of audio?

I have a project that has some ACID files that are perfectly in sync and flexes according to my set tempo. These files are in music mode.

I recorded some additional audio into the project and it was in sync with the project as well but I wanted the ability to change the tempo and have all the audio change in sync; so I put my recorded audio into music mode and it moved from its position in the project and the tempo got screwed for it.

When I look at the details of the Audio file I see that it has extra space before and after the end of the actual audio. I believe someone here told me that this space need to be removed (cleaned) from the audio or else placing it into Music Mode was not going to work.

So how should I do that? I don’t see any option to trim the audio and remove the extra space. Or am I going about this all wrong? :cry:

Well to my experience when I save an acid file I can open it in Cubase and if I change the tempo the track will follow coz its an Acid file . You dont need to adjust music mode at all Give it a try… I do that often and it works perfectly all the time

Thanks for the response Modestl-Expert but maybe I didn’t explain my problem clear enough.

The ACID files aren’t the problem. The problem is with the audio that I recorded into the project in real time. This audio file is not an ACID file and so I believe it needs to be in Music Mode to allow it to flex with the tempo of my song but putting it into Music Mode moves the file out of position and also skews the tempo of the file.

I “think” I need to remove the empty space from the beginning and end of the audio before placing it into Music Mode before it will work properly. Please see the attached screen shot.

But I don’t know how to to that. Or if I should be doing something different.

Yes but maybe I didnt explain my answer enough please consider this. I suggest you to import those tracks in ACID and save it as ACID files then Import it in Cubase and change the tempo as you wish I hope it can help… It works for me

This might be helpful- I hedged what I’m saying since this is not my area of expertise…

If you want to trim that audio to the beginning and end of the event, you can Bounce it. The result will be a file with just the length of the event.

Thanks, I try bouncing and see if it works

No Modest-Expert, I totally understood what you said the first time. But let me explain once more with more detail because I’m apparently still falling short for accurately explaining the issue; or maybe I should say “explaining the full scenario”

Unless I am lacking some knowledge on the topic of ACID, the only way I am aware that you can save an audio file as an ACID wave would be via Sony ACID Pro or some similar product of which I wouldn’t be aware of. I only am aware of Sony’s ACID pro being able to do that. I don’t own ACID Pro.

To add, I probably should have given more specifics to my environment so that’s probably my fault:

Macbook Pro 17
OSX 10.11.3 El Capitan
Cubase 8.5.15

If you believe I can export the wave file as an ACID wave, I’d certainly be very interested in how to do that outside of purchasing Sony’s product. Because even if I owned a Windows system, I wouldn’t want to shell out the $$$ for that product just to perform this task. I would think that Cubase should have some method of doing this.

Yes you need to buy ACID to do that . I personally can’t live without it. Here is how I work I record, import loop etc ,render my track in ACID then I go to Cubase to continue working but in Cubase then, I can change the tempo and all the tracks follow. No need to music mode, or hit points complication . Once it ACidized it follows just like a track in STylus for instance. SYnchronisation is important for me but I want it to be effective, simple and it needs to work all the time. Got no time to lose with synchro headache so I found this way of working and I hope someone here (whos got ACID) will give it a try . But I understand that if you dont have the cash $$$ its a problem No money no candy… :wink: Good luck

Did you ever figure this out?

Cubase is annoying AF. Can’t render any piece of audio without that extra sample bit at the end. Impossible to loop audio seamlessly. For now I’m post editing in Logic.


I’m not 100% on what you want to do but:

You can open the file in the audio editor by double-clicking the audio track you need to work with then enlarge the audio view so you can accurately see the portion of audio you want removed; select the entire section to be removed and from the audio menu [Audio -> Process -> Silence]. This will remove the extra “audio” sample from the wave file.

Or If you want to totally remove the extra audio (instead of simply placing silence there); then enlarge the view of the track large enough to get the details of where you want to trim the file and select the scissor icons from your menu and cut the file.

If this doesn’t answer your question, please give a little more detail and I’m sure I can answer the question for you. No need to post edit in Logic. I’ve been down the road you’re on so whatever the issue is; I can help you out. :slight_smile:

Hey thanks for the response, please view my thread here to see exactly what I mean. Whenever I export audio, there’s automatically more milliseconds at the end of each wave, thus I cannot make seamless loops without using a separate program:

https://www.steinberg.net/forums/viewtopic.php?f=226&t=131055


Hey thanks for the response, please view my thread here to see exactly what I mean. Whenever I export audio, there’s automatically more milliseconds at the end of each wave, thus I cannot make seamless loops without using a separate program:

Ok, so I understand your issue. But actually the answer doesn’t change much from what I’d initially said. I’ve created audio loops within Cubase and have never had the issue you’re describing so I am presuming the title of this thread is what brought you here. But my issue was different although I can see where the title would seem to be descriptive of your problem.

All you need to do is to follow the instructions I’d previously given to clean (trim) your audio and then follow these instructions:

  1. Within the audio editor, set the audio start and end points for the content you want to create the loop. (Making sure you enlarge the view enough to get the 2 points precise)
  2. Playback the audio with the points set and the loop feature engaged and listen to make certain the loop is seamless the way you want (it should constantly playback in loop mode without any gaps.)
  3. Then File->Export->Audio Mixdown
  4. Select your output File Format (I’d suggest .wav as opposed to .mp3 so you can get the purest content uncompressed)
  5. Click Export

Thats it. You should be able to import the exported file on any track and repeat it as many times as you’d like without any extra trailing audio creating glitches. I’ve done it many times without any issue.


In fact, you can also create a loop with characteristics of an ACID file within Cubase as well; which is something I stumbled across after having initially posted this thread and told that I needed to purchase the ACID software to do it; and inevitably told “no money no candy…” because I didn’t want to shell out more $$$ for the additional feature.


To create an ACID type file in Cubase, you’d just add a few more steps to the process:


  1. Within the audio editor, set the beginning and end points of the content you want to create the loop. (Making sure you enlarge the view enough to get the 2 points precise)
  2. Playback the audio with the points set and the loop feature engaged and listen to make certain the loop is seamless the way you want
  3. While the content is playing, go to File -> Project -> Beat Calculator
  4. Make certain the number of Beat per measure is correct for your selected audio. (Its usually fine to just leave it at 4 unless your audio a factor of 3 like 3/4, 6/8 or etc.)
  5. Click on Tap Tempo
  6. Wait for your loop to start at the beginning and begin tapping the space bar with the beat (I’d do this for a couple of loops and note what the average beats per minute are) So as you tap the rhythm, see which value is most consistent because it will generally drift up and down during the session
  7. After you’ve decided which beat value best fits the loop, stop
  8. Select to Insert the tempo "At Tempo Track Start"
  9. The audio will likely shift within the selected area
  10. Within the audio editor, set the beginning and end points of the content you want to create the loop. (Making sure you enlarge the view enough to get the 2 points precise)
  11. Playback the audio with the points set and the loop feature engaged and listen to make certain the loop is seamless the way you want
  12. Within the Audio editor, Select the Free Warp feature
  13. Ensure that each beat aligns perfectly at the start of each measure from the beginning to the end of your selected audio
  14. Then File->Export->Audio Mixdown
  15. Select .wav as your output File Format
  16. Important step: Select to “Insert Tempo Definition”
  17. Click Export

Steps 10 through 13, 15 and 16 are critical to ensure you’ll have an ACID file.

When you import that exported audio loop onto any track, open the Audio editor and click “Musical Mode”

Now when you change the tempo of your project, the audio loop will flex and change as well. You’ve just created an ACID file without purchasing ACID studio. All within Cubase.

The additional steps to set it up may seem a lot written out this way but once you’re familiar the technique, the process should become effortless.

Lastly, if you follow these instructions exactly as I’ve written them and still have an issue; you’re likely doing something wrong. As I’ve said, I’ve never had a problem looping audio seamlessly within Cubase and there is no need to use another program to accomplish that.

I am running Cubase 9.5 but I’ve been able to do this in previous versions as well.

Good Luck! :smiley:

This is very basic stuff, and I’ve done it many times. I don’t even have to enlarge the view because I can just hit “J”, regardless I’ve zoomed in just to make sure. The loops are always seamless in Cubase when I loop it (the wav, not midi). Then once I export it again, and import the wav back into Cubase, that extra piece of audio is always at the end of the wav. It’s bizarre, and there’s literally no answer to it. Other composers doing game audio have also had this issue and we all just use different programs for looping now.

But maybe musical mode will help? I’ll try that and report back, thanks.

As presumed, that did nothing. Pretty sure I tried it before.

Anyway, nothing I do prevents me from exporting audio with unwanted crap at the end of the wav file. Unless there’s some hidden setting I engaged, but I doubt it because I just reformated my PC.

Sorry you’re having the issue but I honestly don’t know or have heard of anyone else having reported such a problem.

What are your system specs and what version of Cubase are you running? If you post that, maybe someone will be able to provide some additional advice but I don’t believe the problem is specific to Cubase else there would have been many other reports.

I’ve had issues with supposedly with Cubase in the past on my system but have come to the hard realization that sometimes the issues I strongly suspect to be the DAW have only been specific to my configuration. Sometimes that’s a bitter pill to swallow but the sooner I accepted that; the quicker I was able to rightfully identify the problem.

A good rule of thumb when you’re having issues and suspect the DAW as the issue is to see if any other users are reporting the identical issue. I’ve found the forum community to be really good at identifying and reporting bugs and issues so when you run across problems that no one else seems to be reporting or having; its very likely specific to your system and the way you have things configured.

And if by chance you do find others having the problem, try to determine what there configurations have in common with your system. Such as what version of windows, version of cubase, memory and etc.

There have been plenty of mentions of this over the years but apart from some specialist uses it doesn’t negatively affect people as theywill lining up the beginning of the event to the grid rather than to end of last event when using loops.

if you think it doesn’t apply to you and it’s a problem with a specific system or user error, please try this and see for yourself.

Start a new project at 44.1k.
Set tempo to 127 (doesn’t need to be this tempo, but some tempos 120bpm for example will give exact line-up)
Add an instrument track and create a one bar event…draw in some notes
Export Audio Mixdown of that track and import back to project
Zoom in as far as possible on the end of the event
The audio event is longer than the midi event…no?

I get your point, (I guess). Still, you should be able to trim and extend the audio to take up a full measure so it can be repeated every bar.

if you think it doesn’t apply to you and it’s a problem with a specific system or user error, please try this and see for yourself.

Start a new project at 44.1k.
Set tempo to 127 (doesn’t need to be this tempo, but some tempos 120bpm for example will give exact line-up)
Add an instrument track and create a one bar event…draw in some notes
Export Audio Mixdown of that track and import back to project
Zoom in as far as possible on the end of the event
The audio event is longer than the midi event…no?

Grim,

Thanks for further clarification of the problem as there was no initial mention of exporting audio directly from a MIDI track. The issue was described with emphasis on the problem with the extra trailing audio at the end of an export and the subsequent having to trim the exported “Audio” using another program.

To be fair, I suppose had I given much thought to the one time mention of

The loops are always seamless in Cubase when I loop it (the wav, not midi)

and read between the lines of that statement against the initially stated concern; perhaps I would have figured it out.

Nonetheless, I followed your instructions in effort to reproduce the issue. Directly exporting the audio generated from 1 bar of the MIDI instrument at 127 bpm and subsequently importing the file back into Cubase and the audio loops seamlessly. I also enlarged the audio and there is no extra audio at the end of the file.

I don’t claim to be an expert by any means but I’ve worked with MIDI and Audio for enough years to know the distinct difference between a MIDI event and the Audio that is generated from the event; and I think it would be more than a reasonable and fair statement to say that no one should realistically expect a MIDI event to be in “perfect” alignment with the audio it generates.

Not to say that it is entirely impossible and achievable with some additional work, but in the very broadest sense that should be (IMHO) a potential realization and not something of surprise. Latency, CPU and other aspects affecting the signal between the trigger and the actual audio play important factors in the outcome.

All that said, should this said anomaly exist for other users (because apparently I must be an exception); then that audio can be trimmed and made useful as a loop within Cubase without having to resort to another product. Which was also the other point I was trying to make. Would you not agree?

I’d be the first to come up with numerous (pet peeves) regarding Cubase and things that I’m not particularly happy with; but that’s speaking off point of the subject. My point is that I haven’t seen any instance during my years of use with Cubase where it cannot trim imported audio and you not be able to perform that within Cubase and have a seamless loop of Audio.

And since its been stated that there obviously is no issue when the audio is looped and the issue is specific to MIDI. Then why wouldn’t one simply route the audio from the VST directly to an audio track, perform any audio trimming and alignment within the audio editor, set the audio to music mode and then export the audio with the tempo definition as I stated?

Could you do me a favour and upload your test project with the one bar of audio as a zip file.
And confirm what version you are testing with…could it be that 9.5 has fixed this?

Would love to work out what the difference is between this extra sample of audio appearing or not.

Just to answer some of your other points:

Well this was just an example repro…the issue is the same regardless of track or media type. Export 1 bar of audio at 127 and this extra sample is also added.

I don’t claim to be an expert by any means but I’ve worked with MIDI and Audio for enough years to know the distinct difference between a MIDI event and the Audio that is generated from the event; and I think it would be more than a reasonable and fair statement to say that no one should realistically expect a MIDI event to be in “perfect” alignment with the audio it generates.

Agreed…but we’re not discussing the timing of the midi compared to the rendered audio but to the end of an event compared to the export marker (loop point)


All that said, should this said anomaly exist for other users (because apparently I must be an exception); then that audio can be trimmed and made useful as a loop within Cubase without having to resort to another product. Which was also the other point I was trying to make. Would you not agree?

No, because of the above…the 1 bar export always has the extra sample

And since its been stated that there obviously is no issue when the audio is looped and the issue is specific to MIDI. Then why wouldn’t one simply route the audio from the VST directly to an audio track, perform any audio trimming and alignment within the audio editor, set the audio to music mode and then export the audio with the tempo definition as I stated?

Was it stated it was specific to midi (other than by you)??
As far as I’m aware the only time this becomes an important issue for people is if they are creating sample libraries…like looping a string sound or piano sustain…that single sample which is no issue in the DAW as it gets overlapped becomes a repeating tick in the external sampler.

No, because of the above…the 1 bar export always has the extra sample

Since when did Cubase not have the capability of inserting silence in a sample or extending the length of a sample (and inserting silence)? Then on second thought, forget I asked the question.

Was it stated it was specific to midi (other than by you)??

Unless I understood his prior response incorrectly, he did say “The loops are always seamless in Cubase when I loop it (the wav, not midi)”. After “you” provided the example in which the audio export was to be generated directly from the VST (MIDI); yes, it would be both an implicit and explicit inclination made other than by me that the issue would be somewhat specific to MIDI since you can’t trigger a VST otherwise.

Nonetheless, none of my responses were without respect to my understanding the issue as it was presented. The more detail provided (which I did ask for previously) the more accurate the response.

The zip file is attached. Good Luck

System Specs:

Mac OSX 10.12 Sierra
Cubase 9.5.10
3.2GHz Processor Quad Core Intel i5
32GB RAM
ExportAudioLoopTest.zip (1.53 MB)