How to reset (midi) Auto Quantize in the Project Window?

Is this a bug or am I missing something?
(Cubase Pro 12.0.51)

When I record midi within a key editor, with Auto Quantize turned on (via the “Automatic MIDI Record Quantize” button in the transport bar), it can be reset afterwards using either “Edit>Reset Quantize” or (in the left zone) “Quantize>Reset Quantize”. Perfect.

But if I record midi directly in the Project Window “Edit>Reset Quantize” doesn’t seem to work. Yes, I have highlighted the midi part first. It’s as if the “Auto Quantize” also applies “Freeze MIDI Quantize”.

I find no comments about this, which makes me wonder if I have missed something important.


I’m wondering is working from the Key Editor in fact. I was thinking it is always recorded processed already. It seems, if you record to the editor, the process (AQ) happens after the recording.

I will have a look on this.

Btw. I strongly recommend always record the raw data/signal and process it afterwards.

Here (0.70) it’s working as expected. With Auto Quantize on, we can then Reset Quantize and we’re back to the raw midi recording. I’m using AQ a lot, and since I many times accidentally have the quantize value set to a “wrong” one, I always use the Reset Quantize with no problem in all versions so far.

1 Like

On my 12.0.60 on PC reset quantize works both in the editor and in the project.
Maybe you should update to the latest version?


@m.c @Johnny_Moneto
It was a good suggestion to update to the latest version. Unfortunately, it didn’t solve the problem.

However, I have now narrowed it down even further.

In the project window. It actually works if I record a new part with auto quantized midi. This is possible to reset. But if I record auto quantized midi into an already existing part, this cannot be reset.

Is there something I am missing? A setting, or something else, that can be turned on or off?


Which MIDI Record Mode exactly do you use, please?

1 Like

I guess as Martin most probably suspects, you’re using the merge mode.
Based on my testing here, when we record upon an existing part in merge mode, the notes of the first parts are affected by reset quantize while the new ones are not.
Same thing happens if we record in cycle mix mode a second layer after a stop.
If nothing went wrong with my testing, I think that this could be considered a bug unless of course there is an underlying logic for this behaviour. @Martin.Jirsak most probably knows a lot more on this.

Anyway, this issue is not there when we have midi mode set to new parts, after all, we can always merge these parts to one when finished with our editing. Actually this is how I work and this is why I never noticed this issue.


@Martin.Jirsak @m.c

Yes, I’ve been using the merge mode. I never realized that the auto quantize behaved differently depending on the mode. I can see some logic to this behavior now.

I will start using your (@m.c ) workflow from now on and keep the mode to new parts.

Much appreciated that you helped me understand what caused this. It started to get annoying to live in the dark :slight_smile: