How to save MIDI Channel setting for VST Instrument channels

Hi, I have an issue for which I cannot seem find the answer in the manual, nor in the topics here. Maybe it’s a dumb question with a simple solution.

I use a VST plugin on an Instrument channel that generates MIDI events (notes with a velocity value) on various MIDI channels.
I also have corresponding VST Instrument channels on the ‘receiving end’ of the MIDI stream to generate sound corresponding to (a part of) the MIDI events generated by the ‘Source VST’.

So in the inspector window I set the MIDI channel for each of the ‘playing’ VST Instrument channels.

image

But every time I restart the project, all the ‘playing’ Instrument channels are set to MIDI channel ANY, so in effect I have all the instruments playing all the MIDI notes of each and every other VST as well.

image

What is the solution to this problem?

Thanks in advance for your help.
Regards.

I may have found an alternative way by using the Input Transformer.
Although this seems to me as an unneccesary complex way to make sure that a VST Instrument only listens to the intended single MIDI channel…

MIDI Channel settings should save with your project. What version of Cubase are you using?

13 Pro.
And no, the MIDI Channel that I set in the routing part of the Inspector (see screenshots above) does not save with the project. Every time I reopen the project all the Instrument tracks are set to ANY again…

Strange, isn’t it?

I’m still on Cubase 12 so unfortunately I can’t confirm. In 12 it works as expected. However I know they added a MIDI Input Channel setting in 13 that previous versions did not have, only a setting for the output of the track.

If you’ve tried all the common troubleshooting steps, such as temporarily moving your Cubase preferences (to rule out them gotten corrupted) and testing starting with a blank project (to rule out any strangeness with a template), I would add the “issue” tag as well as “cubase13”.
Moderator @Martin.Jirsak has a pretty good handle on whether or not it is a known issue or not. You can also contact Steinberg Support from the My Steinberg web page.

@mlib Thanks for your input.
It’s a more or less fresh Cubase install and I started from a fresh empty project, so no templates messing things up.

The workaround with the Transformer gets me where I want to be, although the intended way through the inspector would be far easier. Anyway, let’s see if any usable information is posted.

Thanks for now !!

FYI:
I created User Presets for every MIDI Channel that I need filtered.

DONE :slight_smile: Thanks for this

Hi,

This is a known issue. It’s going to be fixed in the next maintenance update.

Hi,

Cubase 13.0.30 has been released. Please, update.

@Martin.Jirsak
Thanks Martin. Will do after this weekend.

Right now i’m in Beautiful Southern Germany.
Enjoying a short holiday visiting royal castles :grin: