How to select 64 bit cub 7 when clicking on file

I have 64 and 32 bit cubase 7 installed on win 7 64 bit machine. When I select a cubase file that I have created I want it to open in 64 bit cub 7. Instead it is selecting the 32 bit version and I get messages about missing plugins which work fine in 64 bit, but aren’t set up in the 32 bit version. I know that if I launch the 64 bit version and select the file it will work fine with the correct plugins, but I would like to be able to click on the file name to launch 64 bit cubase instead of having to load it first. I tried to select open with from the windows menu and point it to the 64 bit programs folder, but it just continues to load the 32 bit version.
Any help for this minor annoyance?

Maybe you missed to check the ‘Always use the selected program to open this kind of file’ box?

Thanks for the suggestion, but I had checked it and the location it points to is the right folder for the 64 bit version, but I guess it’s not going to work that way since I have both 32 bit and 64 bit versions installed. It seems to default to opening the 32 bit version. I will just have to launch the 64 bit version and then open the file from the file menu, I guess.

Thanks for the encouragement and the step by step instructions, but unfortunately windows is still opening the 32 bit version by default even when I point it to the 64 bit version folder. I would prefer not to disable the 32 bit version which can be useful from time to time, but it’s a real time waster when I double click on the filename and get all these warnings about plugins that aren’t found due to the conflict between the 32 bit and 64 bit programs.

I followed your steps and I had done exactly that the first time and the second time, but I did it again just to make sure I was pointing to the correct folder and it still opens the 32 bit version by default when I double click on a cubase file.

I am still looking for a solution.

you can do it from the registry.

open regedit

go to HKEY_CLASSES_ROOT\Cubase.Document

find shell, then find open, then command

so basically find: HKEY_CLASSES_ROOT\Cubase.Document\shell\open\command

then, change the address to program files rather than program files (x86)

OF COURSE DO THIS IF YOU ARE COMFORTABLE WITH ALTERING YOUR REGISTRY! If you are inexperienced and change a wrong thing, it can lead to more problems…friendly warning :slight_smile:

Do you really need the 32 bit version installed on your computer? If not, uninstall it. I kept it for awhile because the 64 bit version had some issues that weren’t issues in 32 bit, but 7.04 has taken care of those issues now and I don’t need the 32 bit version. The 64 bit version is better for Windows 7 because it can access more of your memory.