How to space individual bar sizes

Hi there!

I wish to resize bars by myself, but in the layout mode - while activated “note spacing” button - the light blue squares at notes and barlines do not react.

What is wrong?


Kindest regards,
Giovanni

You must select one handle and move it with alt-arrow. If you try to move it with your mouse, nothing will happen.

As Marc says, that is the expected behavior. Instead, when you select a box, use alt-arrows for small nudges… and CTRL-alt-arrows for larger adjustments.

The beauty of this UI is that it frees you from the mouse! Use arrow keys to quickly select different boxes. This is the same functionality for Staff Spacing. I’ve quickly grown to love this method.

Thank you for your quick help!

Just one question left regarding spacing of bars : is it possible to simply have an equal spacing of bars regardless of the content of a bar?
(That is quite helpful for creating exam papers with hidden notes…)

Thank you!
Giovanni

What is your goal in hiding notes? Are you aware you can simply have empty bars, and hide the bar rests? That would make the bars of equal width. And you can set casting off under Layout Options --> Staves and Systems.

Just wanting to make sure we help you find the best method of accomplishing what you want, even if it’s not directly answering your question.

Hi there!

My goal in hiding notes is to create two versions of an aural test sheet,

one with the right notes in place
and one with only starting and ending notes.

In that case I found it most likely to hide notes rather than deleating them.
Although I want the bars to have equal size, so that the candidate may not estimate the number of notes on the blank sheet. :wink:

Under Layout Options --> Staves and Systems --> casting off
I can only find the option to restrict the number of bars in a system, but I can’t find an option to have an equal bar size with a deliberate number of bars in a system - for they differ from system to system…

Is there any clue for that?


Kind regards!

Giovanni

The only way to approach achieving that by default would be to change the note spacing ratio on the Note Spacing page of Layout Options to 2.0. But this can still cause the bars to end up different sizes if there are short note values with e.g. accidentals that cause some rhythmic spacing distortion in order to avoid collisions.

Daniel, I have a vague recollection this has been discussed. Is fixed width in the future plans? Thanks.

It’s not in our near-term plans. The reason we might tackle it is when we come to think about music that is spaced according to elapsed time rather than using conventional rhythmic spacing, but that’s not going to be happening soon.